Cannot add a target machine with basic authentification

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

Cannot add a target machine with basic authentification

Postby samer_lm » Mon Mar 10, 2014 8:07 pm

I have Web service project hosted by IIS and configured with basic authentification.
When i try to add it as a target machine, i get this error :

2014-03-10 14:58:56 -04:00 ERROR System.ServiceModel.Security.MessageSecurityException: The HTTP request is unauthorized with client authentication scheme 'Anonymous'. The authentication header received from the server was 'Basic realm="localhost"'. ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized.

How can i configure the deployment manager in order to pass the username and password to the target machine ?
samer_lm
 
Posts: 3
Joined: Mon Mar 10, 2014 7:53 pm

Postby Mike Upton » Tue Mar 11, 2014 12:23 pm

You don't add IIS directly as a target machine; you need to install a Deployment Agent on the server hosting IIS and add that as the target machine. This documentation page should help you get set up.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Postby samer_lm » Tue Mar 11, 2014 1:15 pm

Yes, that s exactly what i did. I just want to add it from my deployment manager server (for my test case, the deployment manager and the web service project are hosted in the same machine). So in the same machine i installed the deployment manager and the Agent service.

I think what is missed here is the user credentials (like the Add sql server form) in order to authenticate to the web service application.
samer_lm
 
Posts: 3
Joined: Mon Mar 10, 2014 7:53 pm

Postby Mike Upton » Tue Mar 11, 2014 1:22 pm

Deployment Manager will never talk directly to your web service application, so it doesn't need the user credentials for the service. The address you should be adding in the 'Add target machine' dialog is the address and port of the Deployment Agent, not your web service. So, if your agent is installed on the same machine as the Deployment Manager server, you'll probably want to use 'localhost' in the address field (i.e. next to the 'http' label), and leave the port field as '10301'.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Postby samer_lm » Tue Mar 11, 2014 1:51 pm

Changing the port was my issue. Now, it works.

Thanks,
samer_lm
 
Posts: 3
Joined: Mon Mar 10, 2014 7:53 pm


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 0 guests