.NET 4.0 support

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings

.NET 4.0 support

Postby redger » Fri Feb 14, 2014 2:52 pm

If I change the target framework to .NET 4.0, I am able to compile the project fine in Visual Studio. When SQL Packager attempts to compile it, it throws errors.

I believe this is because SQL Packager is using a specific version of CSC. Is it possible to change the compiler to use more up-to-date framework?
redger
 
Posts: 2
Joined: Fri Feb 14, 2014 2:45 pm

Postby eddie davis » Mon Feb 17, 2014 3:26 pm

Thank you for your forum post.

Sadly SQL Packager requires that the target machine to have .Net V2 Framework. Therefore I have submitted a Bug Report / Enhancement Request for a future version of SQL Packager to support .Net V4 Framework, the reference for this request is SPA-643.

I cannot guarantee the success of Bug Report / Enhancement Request SPA-643 or if approval is given what future version of the software it will appear in.

Many Thanks
Eddie
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
eddie davis
 
Posts: 943
Joined: Wed Jun 14, 2006 3:47 pm
Location: Red Gate Software


Return to SQL Packager 7

Who is online

Users browsing this forum: No registered users and 0 guests