SQL Search missing in MSSMS 2008

A free Management Studio add-in to search for SQL in your databases

Moderators: JonathanWatts, David Atkinson, Anu Deshpande, Paul Stephenson, Michelle Taylor, Mike Upton, Adam, justin.caldicott

SQL Search missing in MSSMS 2008

Postby vyskol » Wed Feb 05, 2014 5:36 pm

I have a licensed installation of SQL Prompt 6.2.0.366 as well as SQL Search 1.1.9.71.

I have MSSMS 2008 and MSSMS 2012 installed on my computer. In MSSMS 2012, SQL Search appears both in the SQL Prompt menu and the Red Gate toolbar. In MSSMS 2008, it is nowhere to be found.
vyskol
 
Posts: 2
Joined: Fri Mar 09, 2012 4:55 pm

Postby David Pond » Sat Feb 08, 2014 7:39 pm

If you send me a PM with your e-mail address I will put you on the beta list for the new SQL Search release. One of the things we have changed is the way it loads into SSMS*, so I think there's a good chance it will fix the issue you're having.

It now loads through the SSMS Ecosystem project: https://www.simple-talk.com/blogs/2013/ ... ecosystem/
David Pond
Site Admin
 
Posts: 24
Joined: Tue Mar 06, 2012 7:13 pm
Location: Cambridge, UK

Postby Powlin » Fri Mar 28, 2014 7:17 pm

same problem here, I'm using SQL Search 1.1.10.484 and it doesn't load in SSMS 2008.
Powlin
 
Posts: 34
Joined: Wed May 16, 2007 6:56 pm

Postby Chris.Morter » Mon Mar 31, 2014 3:58 pm

Hi Powlin, thanks for participating in the SQL Search beta program. I have tried to reproduce this problem on a fresh install of SSMS 2008 and found that SQL Search did load and function correctly. Do you have any more information that may help us to reproduce this issue?

In particular, did you have any other Red Gate extensions already installed in SSMS when you installed Search? We have recently been doing some development work to provide a common framework to load Red Gate extensions into SSMS and did find some initial problems in testing when the new extension loading mechanism was used alongside the existing one. We believe that these issues have now been resolved, but of course similar issues could remain.

Another possibility is that Search has loaded but the Red Gate toolbar is hidden. Visibility can be toggled by right-clicking some empty space in the SSMS toolbar, and clicking the Red Gate menu item
Chris.Morter
 
Posts: 2
Joined: Wed Jul 17, 2013 4:26 pm

Postby Powlin » Mon Mar 31, 2014 4:06 pm

Hi,

I was using the beta on my computer using Windows XP, it was working fine, i recently got a new computer using Windows 7 and It won't load on it. I tried the 2 last beta and the only one that work is version 1.1.9.57.

Integrated into SSMS, I'm using SQL Prompt, the Tab History was loading but not SQL Search (they are in the same toolbar)

I'm using SSMS 2008 R2 - 10.50.2500.0

Thanks
Powlin
 
Posts: 34
Joined: Wed May 16, 2007 6:56 pm

Still deosn't work

Postby Random Lengths » Thu Apr 24, 2014 8:08 pm

I'm having the same issue with the Beta. I had it working with my SSMS 2008R2, and when I upgraded SSMS to 2012, SQL Search is now gone. I tried the SSMS Integration Pack Framework 1 Repair suggested, and it didn't work.

MUST HAVE MY SEARCH :D
Random Lengths
 
Posts: 28
Joined: Mon Sep 29, 2008 11:02 pm
Location: Eugene, OR

Postby Powlin » Thu Apr 24, 2014 8:16 pm

I've installed the new beta SQL Search 2.0.1.8 and now the SQL Search tab is visible.

I got a new computer at work, and when installed the beta on a fresh installation of SSMS, the SQL Search tab wasn't here, but the Tab History was (I'm using SQL Prompt). Since it was not working I installed the official version that is working.

When a new beta version 2.0.1.8 was available I installed it to see if the problem is corrected and It look like corrected, but maybe it worked because I installed the official SQL Search (1.0.0) before installing the new version.

So maybe you could try installing 2.0.1.8, if it's not working try installing the 1.0.0 and upgrade to 2.0.1.8 after.
Powlin
 
Posts: 34
Joined: Wed May 16, 2007 6:56 pm

Postby Random Lengths » Thu Apr 24, 2014 9:23 pm

I was installing and reinstalling 2.0.1.8. But I tried uninstalling, then reinstalling 1.1.10.484, then installing 2.0.1.8.

My Tab History toolbar is back, but search is still missing.

After restarting SSMS this last time, I got 2 new error messages, perhaps they are related to the issue:

[img]c:\\users\\dlg\\desktop\\2014-04-24_13-12-25.jpg[/img]

[img]c:\\users\\dlg\\desktop\\2014-04-24_13-12-13.jpg[/img]

Though both mention RedGate.SQLSourceControl.SSMS2012.Addin and SQL Source Control seems to be working fine.
Random Lengths
 
Posts: 28
Joined: Mon Sep 29, 2008 11:02 pm
Location: Eugene, OR

Postby domager » Wed May 28, 2014 11:13 am

I'm having the same problem here but with the SQL Search 2 tool, I've recently rebuilt my machine, I'm running Win2008R2.

I first installed SSMS 2012 and then installed the SQL Search 2 tool, and all was working fine.

After finding SSMS 2012 a little sluggish I decided to install SSMS 2008 R2, but the Red Hat menu wasn't showing as an option, so I removed SQL Search 2 and reinstalled, but again it hasn't appeared in 2008, working fine in 2012 though.

Did this get resolved...?
domager
 
Posts: 5
Joined: Wed May 28, 2014 10:36 am

Re:

Postby Random Lengths » Thu May 29, 2014 4:18 pm

domager wrote:I'm having the same problem here but with the SQL Search 2 tool, I've recently rebuilt my machine, I'm running Win2008R2.

I first installed SSMS 2012 and then installed the SQL Search 2 tool, and all was working fine.

After finding SSMS 2012 a little sluggish I decided to install SSMS 2008 R2, but the Red Hat menu wasn't showing as an option, so I removed SQL Search 2 and reinstalled, but again it hasn't appeared in 2008, working fine in 2012 though.

Did this get resolved...?


It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?
Random Lengths
 
Posts: 28
Joined: Mon Sep 29, 2008 11:02 pm
Location: Eugene, OR

Re:

Postby domager » Mon Jun 02, 2014 9:39 am

Random Lengths wrote:It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?


Looks like I'm on a slightly newer version than you, v2.0.1.30
domager
 
Posts: 5
Joined: Wed May 28, 2014 10:36 am

Re:

Postby Random Lengths » Mon Jun 02, 2014 4:07 pm

domager wrote:
Random Lengths wrote:It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?


Looks like I'm on a slightly newer version than you, v2.0.1.30


Sorry, I don't know what else to tell you, other than to contact support. They've always been quick to respond for me.
Random Lengths
 
Posts: 28
Joined: Mon Sep 29, 2008 11:02 pm
Location: Eugene, OR


Return to SQL Search 1

Who is online

Users browsing this forum: No registered users and 1 guest