Connecting the profiler to a target process

Memory profiling for .NET developers

Moderator: dom.smith

Connecting the profiler to a target process

Postby gvfbb » Thu Feb 06, 2014 12:01 pm

hi

I am new in ANTS profiler. My aim is to profile the memory usage of an executing Windows service.
I prepared a service using dotnet and TopShelf. If I run it from VS IDE, I have no problem with memory.
But if I install the service and start it, the executable consumes more and more memory.

So my question is:
is it possible to connect ANTS memory profiler to an executing service, in order to find out what objects consume ram ?

thanks in advance
Giovanni
gvfbb
 
Posts: 1
Joined: Thu Feb 06, 2014 11:53 am

Postby Chris.Allen » Fri Feb 07, 2014 2:09 pm

Yes- if you ensure the project is targeted for >= .Net 4.0

When you select the 'attach to a .net 4 process' option, you will get a list of all process you have permission for.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

The start profiling button is disabled though

Postby aemilianvs » Mon Jul 14, 2014 10:19 am

Hi,

I want to profile the IIS web application.

First scenario:

1. Ran the profiler app as administrator; the web app is running on IIS 6.1, Windows Server 2008 R2 Datacenter
2. Going to attach to .net process page, selected the svchost process corresponding with the W3SVC service
3. The Start profiling button is still disabled, so I am stuck here.

Second scenario:

1. Idem as above
2. Going to IIS - ASP.Net page - says IIS is not installed on this computer, which is obviously false, this is a live IIS server with ASP.Net 4 enabled. So I am stuck here again.

Third scenario

1. Idem as the first one
2. Going to the Windows service page - selected the W3SVC service from the list
3. Pressed the start profiling button
4. The profiling screen says "Starting application" and stays here, although the service starts (as seen in the Services section of Computer management and also in the task manager services section)
So, again, stuck.

Please advise what am I missing.

Thank you!
aemilianvs
 
Posts: 2
Joined: Mon Jul 14, 2014 10:07 am

Application pool identity

Postby aemilianvs » Mon Jul 14, 2014 4:39 pm

I got the solution: I couldn't see the w3wp process in the list, so I could select it (I would have selected it in the first place, but it didn't show int he list) because the application pool was running under the locall system identity instead of application pool identity. Once I switched to the latter, I could select it from the list and could start profiling the process.
aemilianvs
 
Posts: 2
Joined: Mon Jul 14, 2014 10:07 am


Return to ANTS Memory Profiler 8

Who is online

Users browsing this forum: No registered users and 0 guests