/include:StaticData with /option:NoTransactions not working

Compares and synchronizes SQL Server databases, backups and scripts.

Moderators: JonathanWatts, Chris Auckland, David Atkinson, eddie davis, Anu Deshpande, Michelle Taylor, alice.easey, james.billings, chengvoon.tong

/include:StaticData with /option:NoTransactions not working

Postby ddorval » Fri Jan 31, 2014 5:38 pm

Our msbuild build script is executing sqlcompare twice with everything the same except the 2nd time we include NoTransactions on the option list.

/options:Default,IgnoreTSQLT,IgnoreUsersPermissionsAndRoleMemberships
and then
/options:Default,IgnoreTSQLT,NoTransactions,IgnoreUsersPermissionsAndRoleMemberships

This is the only different between the 2 executions. The first includes the sql code to insert a new static data row, the 2nd does not. The output at the command window shows both finding the stat data difference.

Full Command Line (paths/files redacted):

sqlcompare /scripts1:"***" /scripts2:"****" /scriptfile:"****" /options:Default,IgnoreTSQLT,IgnoreUsersPermissionsAndRoleMemberships /force /migrationsfolder:"****" /scriptsfolderxml:****" /revision1:1172 /revision2:1151 /Exclude:Synonym /Exclude:User /include:StaticData

The only difference is the /optons: (see above) and /scriptfile:""


This is happening on the build server
SQL Compare Command Line V10.5.0.378
and my local machine
SQL Compare Command Line V10.4.8.87
ddorval
 
Posts: 8
Joined: Thu Nov 08, 2012 9:13 pm

Postby Brian Donahue » Mon Feb 03, 2014 5:22 pm

I have replied to you directly via the support ticket as this is a complex and individual issue.

Thanks for your patience.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to SQL Compare 10

Who is online

Users browsing this forum: No registered users and 0 guests