Deployment Manager over SSL, DNS and Port 443

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

Deployment Manager over SSL, DNS and Port 443

Postby dcoyle » Tue Aug 20, 2013 2:15 am

Hi,

I've been trying to get Deployment Manager to run over SSL Port 443 and a custom DNS address such as:
https://deploy.mycompany.com

I've made the normal changes in IIS fine and the WebApp seems to run fine. I can also connect to the server from the VS studio plugin - however when I try to Publish a Package via the Visual Studio plugin it times-out. In each case it seems to want to resolve the address back to the servers name and http running on port 443 i.e:

http://myservername.localdomain.local:443

Firstly:
1.) Can I do what I am trying to do?
2.) how do I modify the internal DNS name that Deployment Manager keeps using.

Thanks
dcoyle
 
Posts: 2
Joined: Tue Aug 20, 2013 1:51 am

Postby Emma A » Tue Aug 20, 2013 1:48 pm

Hello,
Yes Deployment manager should work in this situation although it is not something that we officially support.

I believe that you are trying to publish to the embedded nuget feed that is installed with Deployment Manager. To do this you will need to change a registry key value, using regedit.exe. You will need to change the value of the EmbeddedNuGetUri String value key in [HKEY_LOCAL_MACHINE\\SOFTWARE\\Red Gate\\Deployment Manager] to https://deploy.mycompany.com:443/nuget/ and then restart the Red Gate Deployment Manager service in Services.msc.

The Visual Studio plugin asks Deployment Manager for the list of feeds, which it obtains from the information stored on the Package feeds page. You may also need to change the value listed here to match the value that you put in the registry although the service restart should do this. The Package feeds page can be accessed via the Settings tab.

Please be aware that if you run the Server Tools application, this will reset the bindings of your deployment manager server and the embedded Nuget feed.

Hope that helps.
Emma
Emma A
 
Posts: 40
Joined: Mon Mar 30, 2009 2:53 pm

Postby dcoyle » Wed Aug 21, 2013 8:03 am

Thanks that worked great.

Given changes in last version for including Windows Authentication it would also be great if access to NuGet Feed also required this security.

Thanks again.
dcoyle
 
Posts: 2
Joined: Tue Aug 20, 2013 1:51 am

Deployment Manager over SSL, DNS and Port 443

Postby haans74 » Thu Jan 30, 2014 8:52 pm

This fix does not seem to be working for me. I edit the value of the EmbeddedNuGetUri String to https but something is forcing it back to http whenever the web site is restarted.
Also in Server Tools, the port updates to 443 but the URI will always stay at http:
I'm able to get to the site if I manually type in https://deploy.....
Has anyone out there seen this when trying to setup the web site to use SSL, port 443?
haans74
 
Posts: 6
Joined: Thu Jan 30, 2014 8:43 pm

Postby Mike Upton » Thu Jan 30, 2014 9:06 pm

Can I just check that you remembered to restart the Windows service (Red Gate Deployment Manager) after changing the registry value, not the web site?
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Deployment Manager over SSL, DNS and Port 443

Postby haans74 » Thu Jan 30, 2014 10:04 pm

Thanks Mike, you were right I missed the service restart. The registry value has saved correctly with https.
Any idea about the other thing with the URI on the server tools staying with http?
haans74
 
Posts: 6
Joined: Thu Jan 30, 2014 8:43 pm

Postby Mike Upton » Fri Jan 31, 2014 10:41 am

I'm glad that's fixed it for you. The Server tools app shows 'http' because it doesn't understand the HTTPS configuration (we don't officially support this configuration yet), but that shouldn't affect anything else, as long as you don't use it to change the port.

We do intend to make HTTPS a properly supported configuration at some point.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 0 guests