This implementation is not part of the Windows Platform FIPS

Compares and synchronizes SQL Server databases, backups and scripts.

Moderators: JonathanWatts, Chris Auckland, David Atkinson, eddie davis, Anu Deshpande, Michelle Taylor, alice.easey, james.billings, chengvoon.tong

This implementation is not part of the Windows Platform FIPS

Postby SenseiTim » Fri Jan 24, 2014 4:44 pm

I was trying to run a compare between 2 databases on the same server and received the following error message: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.

According to Microsoft there is a hotfix available (KB935434). Does anyone know if this will address the problem we are experiencing?
SenseiTim
 
Posts: 1
Joined: Fri Jan 24, 2014 4:38 pm
Location: Atlanta

Postby Anu Deshpande » Mon Jan 27, 2014 11:43 am

Thanks for your post.

I have logged a support ticket for you and will email you shortly.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby wilson1139 » Thu Apr 03, 2014 9:00 pm

Anu,

What was the answer to this problem? I am having the same issue.

Thanks,
George Wilson
wilson1139
 
Posts: 1
Joined: Thu Apr 03, 2014 7:23 pm
Location: Durango, CO

FIPS

Postby Rich.Kennedy » Wed Jul 09, 2014 8:32 pm

Anu,

What was the answer to this problem? I am having the same issue.

Thanks,

Rich
Rich.Kennedy
 
Posts: 1
Joined: Wed Jul 09, 2014 8:22 pm

Postby Evan Moss » Wed Aug 06, 2014 10:07 pm

Hello,

This error happens when FIPS policy checking is enabled. You can tell whether it's enabled by checking the registry key here: HKLM\\System\\CurrentControlSet\\Control\\Lsa\\FIPSAlgorithmPolicy\\Enabled (1 is enabled and 0 is disabled).

If you're allowed to disable it, you can change the value of that key to 0. You can also try creating a config file in the same folder as the .exe with the same name as the .exe. For example, in C:\\Program Files (x86)\\Red Gate\\SQL Compare 10, create a file called RedGate.SQLCompare.UI.exe.config.

You'll need the config file to contain the following:

<?xml version="1.0" encoding="utf-8"?>
<configuration>
<startup>
<runtime>
<enforceFIPSPolicy enabled="false"/>
</runtime>
</startup>
</configuration>

This might not work in certain locked down environments.

Hope that helps.

Thanks,
Evan
Evan Moss
Product Support
(866) 627-8107
Evan Moss
 
Posts: 99
Joined: Wed Jun 12, 2013 9:56 pm


Return to SQL Compare 10

Who is online

Users browsing this forum: No registered users and 1 guest