sqlbackup.exe

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

sqlbackup.exe

Postby kterry » Thu Jan 09, 2014 8:58 pm

We have a windows 2012 R2 cluster, sql 2012, with two nodes, call them:
ServerA
ServerB
Sql virtual name: Sql_Cluster

We log ship some databases to above cluster, or will be, we're setting up/testing this now. I've run into a problem trying to run command line of sql backup (SqlBackupC.exe).
We only use default instances, don't have any sql servers with a named instance. On our current servers (not the cluster ) we can run :
SqlBackupC.exe -SQL "RESTORE LOG [DB] FROM DISK = [E:\\backup\\DB_10140108_123550_LOG.sqb]
WITH STANDBY = [E:\\backup\\StandByFiles\\DB.dat], PASSWORD = [DBPWD], MOVETO=[Complete\\db]" -E

and will run fine.
If I run same script on our cluster, I get error
SQL error 17: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
Server :
Windows authentication
1/9/2014 7:48:51 AM: Failed to connect to SQL Server instance:

My user account is a sys admin on this sql. It looks to me like it is trying to use machine name as name of sql server, so trying to connect to sql named: serverA, we don't have that, since is cluster, sql is called sql_cluster. In trying to force it to connect to proper sql name, I looked for a -S or some parameter to pass in server name, but only saw -I for instance name. if i try -I and put in sql_cluster, it fails, looking for server: serverA/sql_cluster, we don't have named instance like that so that fails.
If a use -I (local) it works,
Somehow it uses different method to find sql server name if I omit it, different than if I pass -I (local) ? That seems strange, so maybe I'm missing something? I would expect all clusters to have this make up, where have 2 + servers, and sql on it but w/ diff name than the actual server name. Might our cluster not be set up right?
kterry
 
Posts: 1
Joined: Thu Jan 09, 2014 8:42 pm

Postby petey » Fri Jan 10, 2014 8:26 am

It's a bug in SQL Backup when the default instance is a clustered instance. The workaround is as you mentioned: use the -I parameter with (local) or . i.e.

sqlbackupc -sql "BACKUP ..." -I (local)

or

sqlbackupc -sql "BACKUP ..." -I .

A bug report has been raised (SB-5555).
Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 7
petey
 
Posts: 2226
Joined: Sun Apr 24, 2005 12:34 pm


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 0 guests