SQL Backup 7.4 fresh install not detecting SQL cluster

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

SQL Backup 7.4 fresh install not detecting SQL cluster

Postby jhboricua » Thu Oct 31, 2013 9:10 pm

When I run the setup file from the active node of a SQL cluster, in this case a SQL 2008 R2 cluster running on Server 2008 R2 Enterprise, the installer fails to detect that it's on a cluster.

I don't get any of the cluster related dialog windows shown on your instructions for cluster installs per the link: http://www.red-gate.com/supportcenter/Content/SQL_Backup/help/7.2/SBU_InstallingonaSQLServerCluster

Therefore, the installer simply asks me where to install to, which defaults to the C: drive.

What's the deal?
jhboricua
 
Posts: 30
Joined: Tue Mar 15, 2011 3:54 pm

Postby eddie davis » Mon Nov 04, 2013 1:39 pm

Thank you for your forum post and sorry that you have encountered a problem.


I am not aware of any problems with regards to Windows 2008 R2 / SQL 2008 R2 clusters with SQL Backup 7.4. I am aware of a problem with Windows 2012 clusters.

Can you please search the registry for this GUID {F2E606E0-2631-11D1-89F1-00A0C90D061E} regarding an interface called IsClusPartitionEx? The GUID value should have a matching clustering component. If not it would appear that a clustering component was not registered on the server.

Does the current active node for your clustered instance include or have installed a non-clustered instance of SQL that the installer may have detected?

Many Thanks
Eddie
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
eddie davis
 
Posts: 943
Joined: Wed Jun 14, 2006 3:47 pm
Location: Red Gate Software


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 0 guests