Deployment Agent Service intermittently does not start

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

Deployment Agent Service intermittently does not start

Postby markb_nz » Thu Oct 03, 2013 2:07 am

I am finding that when I restart machines running the deployment agent service that the service sometimes does not start. If I manually restart the service it works fine.

I tried adding a task to run net start after a delay (~1min), but I am still sometimes seeing the isssue.

All the machines are VMware VMs running Windows Server 2012. I am running Redgate DM Enterprise v2.2.4.1.

I can't see any log file or events in the event viewer. Any ideas on what might be the cause, or how I can turn some debugging on to find out?

Cheers,
Mark
markb_nz
 
Posts: 2
Joined: Thu Oct 03, 2013 2:00 am

Postby james.billings » Thu Oct 03, 2013 9:09 am

Hi Mark

I've not personally heard of this one before unfortunately. The DM Agent doesn't seem to have dependencies on any other windows services at all, and I don't think it'll have logged anything if it didn't start. Have you tried looking in the windows event logs for anything useful?

The only thing it'll try and do at startup would be to bind to the network port it listens on so if the network is unavailable or the windows firewall is in an odd state where it won't let it use the port, that's one possibility?
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby DatabaseJase » Tue Oct 15, 2013 4:30 pm

I've experienced this issue also with servers running in a VMware environment and also my own PC (used to test releases until we get the ability to remove them in a future release).

The solution I am using and seems to be most effective is to change the service startup to "Automatic (Delayed Start)" but the problem is any upgrade of the agent removes and recreates the service so reverts to just "Automatic".

Could that become the default startup setting for the agent service in a future release?
DatabaseJase
 
Posts: 7
Joined: Fri Sep 20, 2013 10:53 am
Location: Northamptonshire

Postby Mike Upton » Wed Oct 16, 2013 11:30 am

Delayed start is a good idea. I'll get that changed for the next release.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Postby Mike Upton » Sat Nov 30, 2013 4:40 pm

Just wanted to let you know that this change was made in Wednesday's release of Deployment Manager, version 2.3.8.33. Both the Deployment Manager Server and Agent services are now set to Automatic (Delayed) start.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 0 guests