sql prompt performance bad

Provides intelligent code completion for SQL Server editors.

Moderators: Anu Deshpande, Aaron Law, David Priddle

Postby CGLuttrell » Thu Sep 12, 2013 10:22 pm

Aaron, I downloaded your 6.1.0.42 version and it does seem better for me so far. I turned off synonyms but did not see the option for partial matches. I will continue to test and monitor for future updates.
CGLuttrell
 
Posts: 18
Joined: Thu Sep 10, 2009 9:25 pm
Location: Knoxville, TN

Postby kondrich » Fri Sep 13, 2013 10:41 am

Yes, I am referring to SSMS built in IntelliSense that I completely deactivated to prevent lags in SQL Prompt (auto-list members was already deactivated to get suggestions just from SQL Prompt).

I just checked my display drivers: They are up to date (both checked Dell and Intel driver sites).

We tried a remote session once, but it did not work. I suspect our restricted network via a proxy that requires authentication. But we could try once more...

After typing "ssf <tab>" the list of suggested objects displays. When hitting cursor down reasonably fast, I could hit it ten times until the the cursor actually moves down.
Regards, Klaus
kondrich
 
Posts: 60
Joined: Thu Jun 10, 2010 10:44 am
Location: Vienna, Austria

6.1.0.42

Postby ephraim » Fri Sep 13, 2013 1:12 pm

I downloaded 6.1.0.42 and it indeed performs much better, thanks. I got one crash which automailed through to you. I'll test further in the next days and let you know how it goes, but so far its promising. Thanks, Ephraim
ephraim
 
Posts: 15
Joined: Sat Sep 07, 2013 3:48 pm
Location: United States

6.1.0.42

Postby ephraim » Fri Sep 13, 2013 1:28 pm

I downloaded 6.1.0.42 and it indeed performs much better, thanks. I got one crash which automailed through to you. I'll test further in the next days and let you know how it goes, but so far its promising. Thanks, Ephraim
ephraim
 
Posts: 15
Joined: Sat Sep 07, 2013 3:48 pm
Location: United States

Postby Aaron Law » Fri Sep 13, 2013 5:17 pm

CGLuttrell and Ephraim, I'm very glad to hear this seems to have fixed the lag for you.
I received the error report sent in and should have a fix in 6.1.0.46.

Klaus, your problem does sound like it's different from what the other people in the thread are seeing. Can I ask which features of the built in IntelliSense do you use?
Aaron Law
 
Posts: 250
Joined: Fri Jun 28, 2013 10:56 am
Location: Red Gate Software

Postby kondrich » Mon Sep 16, 2013 7:30 am

I have SSMS IntelliSense turned on with "Underline errors" and "Outline statements" activated. "Autolist parameters" and "Parameter information" are turned off (I think those are standard settings).
I tried to turn off "Underline errors" and "Outline statements" (just IntelliSense remains on), but this does not change anything.
Regards, Klaus
kondrich
 
Posts: 60
Joined: Thu Jun 10, 2010 10:44 am
Location: Vienna, Austria

Postby Aaron Law » Mon Sep 23, 2013 2:02 pm

Hi Klaus, I've logged your bug as SP-4862 in our bug tracking system, I guess the workaround for now is to disable the native intellisense. One possibility is for us to implement these features in prompt so the native intellisense doesn't need to be turned on.

Ephraim and CGLuttrell: I've just released 6.1 as our stable build if you'd like to update.
Aaron Law
 
Posts: 250
Joined: Fri Jun 28, 2013 10:56 am
Location: Red Gate Software

Postby kondrich » Tue Sep 24, 2013 3:18 pm

Aaron, thank you for releasing 6.1.

Disabling native Intellisense indeed removes all lags as a workaround. I guess that it would be a long way to re-implement all features of Intellisense.
I just want to know where this lags come from. As I checked on our servers, a faster hardware would minimize them. However, they do not disappear.
Regards, Klaus
kondrich
 
Posts: 60
Joined: Thu Jun 10, 2010 10:44 am
Location: Vienna, Austria

Previous

Return to SQL Prompt 6

Who is online

Users browsing this forum: No registered users and 0 guests