Windows 2003 server issue with RedGateReleaseNumber

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

Windows 2003 server issue with RedGateReleaseNumber

Postby rjayakumar » Wed Aug 21, 2013 8:00 am

I am trying to use physical path to deploy as
x:\\AppName_$(RedGateReleaseNumber) and DM though created the physical folder - it failed to deploy any further files in to the newly created folder.

I am missing any other setting?

The other settings are as below

RedGateCreateWebSiteOnPort - 80
RedGateNotAWebSite - True
RedGatePurgePackageDirectoryBeforeCopy - True
RedGateWebSiteName - Default Web Site/AppName

The error message from the log is as below:

2013-08-21 06:32:17 INFO Purging the directory 'X:\\AppPublish\\AppName_1.8.3.1108'
2013-08-21 06:32:18 INFO Extracting package contents to 'X:\\AppPublish\\AppName_1.8.3.1108'
2013-08-21 06:32:18 ERROR Access to the path 'X:\\AppPublish\\AppName_1.8.3.1108\\AccessDenied.aspx' is denied.
________
Cheers,
Raghunandan
rjayakumar
 
Posts: 25
Joined: Wed Aug 21, 2013 7:49 am
Location: Bangalore

Postby Mike Upton » Wed Aug 21, 2013 3:25 pm

Hi,

I've already replied to your support e-mail about this, but for the benefit of any others who might be reading this...

The access denied message means that the OS on your target machine is denying access to the specified folder, either due to permissions set on the target folder or because another process is locking the file. If you haven't customised any of the folder security settings, the most likely culprit is a virus scanner.
Mike Upton

Software Engineer
Red Gate Software Ltd.
Mike Upton
 
Posts: 157
Joined: Wed May 11, 2011 8:04 am
Location: Red Gate

Postby rjayakumar » Fri Aug 23, 2013 8:46 am

Mike,
the issue was more w.r.t the new physical path and the path associated to virtual directory mismatch. After having marked NotAWebsite = False - the new physical path has been set for virtual directory and the access denied is not appearing any more.

May be it is to do with the parameter value that the DM is looking to deploy the files.
________
Cheers,
Raghunandan
rjayakumar
 
Posts: 25
Joined: Wed Aug 21, 2013 7:49 am
Location: Bangalore

Postby rjayakumar » Fri Aug 23, 2013 8:49 am

Mike,
the issue was existing in 2003 still exists when the new path is used from the parameter. I am not sure of any security features affecting the deployment.

If we deploy without having to change the physical path - then there are no issues.

Would you mind for a quick screen share session?
________
Cheers,
Raghunandan
rjayakumar
 
Posts: 25
Joined: Wed Aug 21, 2013 7:49 am
Location: Bangalore


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 0 guests