Schema Compare 3.0.0.689 - bug report

Compares and synchronizes the schemas of Oracle databases

Moderators: eddie davis, richardjm, Michael Christofides, neil.anderson

Schema Compare 3.0.0.689 - bug report

Postby steve B » Mon Jul 29, 2013 3:30 pm

Bug report:

1. Create comments on the columns of a VIEW in the database (Oracle XE 11.2.0.2.0)
2. Use schema compare v3.0.0.689 to generate scripts - runs OK
3. Use schema compare v3.0.0.689 to re-create objects in database schema from scripts - FAILS

The Schema Compare run in step 3 fails when running deployment script with "Error: ORA-00911: invalid character"

Removing the "comment on column view.column is '...'" commands from the "create view" script seems to fix the problem - so assume that these comments are the cause of the problem.

Could someone please confirm whether
(1) This is a bug?

and

(2) When we can expect a new version of Schema Compare that fixes this (and the 2 previously reported bugs)?
steve B
 
Posts: 4
Joined: Tue Jul 23, 2013 2:25 pm

Postby neil.anderson » Wed Jul 31, 2013 11:02 am

Hi Steve,

Thanks for getting in touch. This could be a bug but as ever, it depends. Can you post here or send to oracle@red-gate.com the SQL the Schema Compare is outputting that causes this problem?

I think it could be either we're outputting invalid SQL or the target you are deploying to has a different character set than the source (assuming it is a different database).

Thanks,
Neil
neil.anderson
 
Posts: 64
Joined: Tue Sep 28, 2010 2:17 pm


Return to Schema Compare for Oracle

Who is online

Users browsing this forum: No registered users and 0 guests