How to restore Studio 2010/2012 ANTS menu

Code profiling for .NET developers.

Moderator: dom.smith

How to restore Studio 2010/2012 ANTS menu

Postby rstewart27104 » Wed Jul 24, 2013 6:55 pm

I am using the .NET Developer Bundle which contains VS 2010/2012 integration.

I recently (today) installed the latest ReSharper, version 8. After installation and launching either VS2010 or VS2012, the .NET Reflector menu is present however the ANTS menu is gone...

My question is how can I quickly restore the ANTS menu without reinstalling the bundle? If reinstall is required, do I have to 'Deactivate the Serial Numbers' beforehand or is the installer smart enough to retain my license?
rstewart27104
 
Posts: 4
Joined: Wed Jul 24, 2013 6:35 pm

Postby jessica.ramos » Thu Jul 25, 2013 7:28 pm

Hi there, thanks for your post!

You may be able to avoid a reinstall if you open VS, go to Tools->options->add-in security, and (if it's missing) re-add a path to the "ANTS Profiler Visual Studio Add-in 1" there (the path should be c:\\program files\\red gate\\ants profiler visual studio add-in 1\\), and make sure that that folder has the RedGate.ANTSVsAddin.addin file and the RedGate.ANTSVsAddin.dll.

Should that not help though, please do try a reinstall of just the add-in-- your license should be retained :)

Hope that helps!
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm

Postby rstewart27104 » Thu Jul 25, 2013 8:04 pm

Everything under 'Tools->Options->Environment->Add-in/Macros Security' was present and matched what you described. The addin and dll files were also present in the given path.

I then reinstalled the add-in with no success. The ANTS menu is still missing in both VS2010 & VS2012.
rstewart27104
 
Posts: 4
Joined: Wed Jul 24, 2013 6:35 pm

Postby rstewart27104 » Thu Jul 25, 2013 8:07 pm

BTW
I do have an open ticket on the R# support site at ReSharper 8 removes another third party Studio menu
rstewart27104
 
Posts: 4
Joined: Wed Jul 24, 2013 6:35 pm

Postby jessica.ramos » Fri Jul 26, 2013 10:19 pm

Sorry to hear that didn't help! Could you please check if "allow add-in components to load" is enabled? You may also just need to delete the following registry key to reset the add-in's location:

HKEY_CURRENT_USER\\Software\\Red Gate\\ANTS Profiler Visual Studio Add-in 1

(Also, thanks for logging the issue with the Resharper team!)
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm

Postby rstewart27104 » Mon Jul 29, 2013 1:51 pm

Deleting the registry key worked. The menu was restored after the deleting the key and restarting VS2010/2012.

Suggestion:
Your add-in should be more reactive when integrating with the menu. If its static location (which you store in the registry) is not found due to other 3rd party tools being installed/uninstalled, don't give up. Determine a new menu location and update the registry instead of giving up and not displaying a menu.
rstewart27104
 
Posts: 4
Joined: Wed Jul 24, 2013 6:35 pm

Postby jessica.ramos » Wed Jul 31, 2013 4:26 pm

That's great news :D

And many thanks for the feedback--I'll note it down.
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm


Return to ANTS Performance Profiler 8

Who is online

Users browsing this forum: No registered users and 0 guests