Test Search for Nuget packages times out

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

Test Search for Nuget packages times out

Postby jtucker@inflexxion.com » Wed Jul 03, 2013 4:30 pm

In Settings->Package Feeds->Test Action link anything I search for (including packages that I know are there), times out. Any ideas what is going wrong?
jtucker@inflexxion.com
 
Posts: 12
Joined: Thu Jun 27, 2013 10:23 pm
Location: Boston

Postby james.billings » Thu Jul 04, 2013 8:28 am

Can you try visiting the feed URL in a browser? You should see some XML output if it's online and working. If you're still having trouble, then what feed is it (i.e. the built in DM one / TeamCity / something else?)

A timeout would normally indicate either a communication problem to the machine in question or the required service isn't running.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Follow-up on feed problem

Postby jtucker@inflexxion.com » Wed Jul 10, 2013 12:55 pm

I did visit the url and got the expected xml. It is the built-in feed from DM. It is still timing out. What is the name of the service? Is it a windows service?
jtucker@inflexxion.com
 
Posts: 12
Joined: Thu Jun 27, 2013 10:23 pm
Location: Boston

but i did find this

Postby jtucker@inflexxion.com » Wed Jul 10, 2013 1:00 pm

I looked on the machine where the Nuget feed is installed. I do see the nuget virtual directory and it maps to e:\\program files (x86)\\Red Gate\\Deployment Manager\\NuGet. In the App_Data there is this error xml: <error time="2013-07-10T11:16:31.2402473Z" detail="System.IO.DirectoryNotFoundException: Could not find a part of the path 'E:\\Program Files (x86)\\Red Gate\\Deployment Manager\\NuGet'. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileSystemEnumerableIterator`1.CommonInit() at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost) at System.IO.Directory.EnumerateFiles(String path) at System.Web.WebPages.Deployment.PreApplicationStartCode.OnChanged(String key, Object value, CacheItemRemovedReason reason) at System.Web.Caching.CacheEntry.CallCacheItemRemovedCallback(CacheItemRemovedCallback callback, CacheItemRemovedReason reason)" source="mscorlib" message="Could not find a part of the path 'E:\\Program Files (x86)\\Red Gate\\Deployment Manager\\NuGet'." type="System.IO.DirectoryNotFoundException" host="ILBUILD02" errorId="c7152bff-b0ad-46c7-a23f-580e89c0fb0f"/>
jtucker@inflexxion.com
 
Posts: 12
Joined: Thu Jun 27, 2013 10:23 pm
Location: Boston

Postby james.billings » Wed Jul 10, 2013 2:38 pm

Is it perhaps permissions related then? So it doesn't have access to that folder?
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.


Return to Deployment Manager

Who is online

Users browsing this forum: No registered users and 1 guest