Command line automation does not sync extended properties

Compares and synchronizes SQL Server databases, backups and scripts.

Moderators: JonathanWatts, Chris Auckland, David Atkinson, eddie davis, Anu Deshpande, Michelle Taylor, alice.easey, james.billings, chengvoon.tong

Command line automation does not sync extended properties

Postby ZHCS » Fri May 17, 2013 12:36 pm

We are using SQLCompare.exe for automated deployment of our databases. We realized that the deployment script created by sqlcompare.exe doesnt not synchronize extended properties of the databases. When i try to create the deployment script from SQL Compare GUI, the resulting script does include part synchronizing the extended properties. The options in GUI and for command line set up in identical way. We are not using Ignore extended properties option. Any ideas?
ZHCS
 
Posts: 4
Joined: Fri May 17, 2013 12:14 pm

Postby james.billings » Mon May 20, 2013 6:18 pm

Thanks for your post.

Based on an initial test here, DB level extended properties should get scripted OK, so I need to check a few things:

- are these extended properties the ones that SQL Source Control adds, or your own ones?
- are you running the command line with the same credentials as when you tried it through the GUI?
- what version of SQL Compare are you on?
- what *exact* command line are you running? Can you post an example? For instance I was able to script the differences in extended properties with pretty much no options:

Code: Select all
sqlcompare.exe /db1:database1 /db2:database2 /sf:d:\\sync.sql
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby ZHCS » Tue May 21, 2013 12:35 pm

Hi,

Many thanks for your response.

- these are the extended properties which SQL Source Control adds
- No, i am running the command line with different credentials. What permissions would i need to be able to synchronize the extended properties?
- we have SQL Compare 10
- /scr1:"%system.teamcity.build.checkoutDir%" /revision1:HEAD /server2:XXXXX /db2:XXXXX /Include:identical /o:Default /Report:XXXXX /ReportType:Simple /ScriptFile:XXXXX /Force /logLevel:Verbose /sync
ZHCS
 
Posts: 4
Joined: Fri May 17, 2013 12:14 pm

Postby james.billings » Tue May 21, 2013 12:38 pm

DB level extended properties require DB Owner permission, so I'd check that first.

There's a Compare option to ignore the Source Control properties, but this is not set by default and you don't seem to be specifying it as far as I can tell.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby ZHCS » Wed Jun 12, 2013 8:26 am

Hi James,

I am sorry for getting back to you so late on this subject but unfortunately we didnt make any progress on this.

I found out that we are running the command line with credentials which have DB owner permissions

I have SQL Compare version 10.2.6.114. One of my collegues has the same version, the same settings and the same permissions but when he creates the scripts he doesnt have also these extended properties scripted!

Another collegue has higher version, the same setting but still dont get the extended properties!

Any ideas?
ZHCS
 
Posts: 4
Joined: Fri May 17, 2013 12:14 pm

Postby james.billings » Wed Jun 12, 2013 12:47 pm

Ah, I wonder if the problem here is because you're working with script folders. I don't /think/ these have the extended properties in.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby ZHCS » Wed Jun 12, 2013 4:16 pm

Thanks James!

Looks like this is exactly the issue we are having.
ZHCS
 
Posts: 4
Joined: Fri May 17, 2013 12:14 pm

Postby james.billings » Wed Jun 12, 2013 4:17 pm

Ah yes,

As far as I know, this is by design unfortunately.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.


Return to SQL Compare 10

Who is online

Users browsing this forum: No registered users and 2 guests