Unable to connect to Base Monitor after upgrade of server

SQL Server performance monitoring and alerting

Moderators: eddie davis, priyasinha, Adam, chriskelly, Chris Lambrou, Chris Spencer

Unable to connect to Base Monitor after upgrade of server

Postby absnom » Wed Apr 10, 2013 11:18 pm

We had SQL Monitor up and running on an Amazon EC2 instance. We upgraded the instance to increase the memory and CPU on the vm and now the web app fails to connect to the Base Monitor. The Base Monitor service is up and running and appears to be listening on port 7399.

On the "Unable to connect..." web page, if I click on the "Connect to Base Monitor" button, I get the message:

"Attempted to read or write protected memory. This is often an indication that other memory is corrupt."

We tried a complete re-install, but unfortunately get the exact same error message.

We are using SQL Monitor 3.3 running on Windows Server 2012, with SQL Server 2012 and IIS 8.

Thanks for your help.
absnom
 
Posts: 4
Joined: Thu Apr 04, 2013 5:17 pm

Postby Manfred.Castro » Fri Apr 12, 2013 12:05 am

Could you try editing the advanced properties on the app-pool to show Enable 32-bit applications as true?

This should hopefully resolve the issue.
Manfred Castro
Product Support
Red Gate Software
Manfred.Castro
 
Posts: 209
Joined: Mon Apr 23, 2012 2:49 pm

Postby absnom » Fri Apr 12, 2013 3:35 pm

Manfred,

That was it. It's working fine now. Thank you very much for your help.
absnom
 
Posts: 4
Joined: Thu Apr 04, 2013 5:17 pm


Return to SQL Monitor 3

Who is online

Users browsing this forum: No registered users and 1 guest