Persistent, Intermittent, WMI errors - SOLVED

SQL Server performance monitoring and alerting

Moderators: eddie davis, priyasinha, Adam, chriskelly, Chris Lambrou, Chris Spencer

Persistent, Intermittent, WMI errors - SOLVED

Postby PDinCA » Sat Feb 02, 2013 2:38 am

Monitor (3.2.0.219), Running as: NT AUTHORITY\\SYSTEM (Service)
Also, using a sysadmin DB server role for the cluster name, and 2 nodes login, with SQL sa as the "local" credentials.

Usually at least 3 or 4 times a week, sometimes twice a day, at unpredictable times, SQL Monitor will send an Alert:
Code: Select all
ID:   2490436
SQL Server:   (local)
Machine:   <<The Cluster>>
Alert type:   Monitoring error (SQL Server data collection)
Level:   None
Time raised:   1 Feb 2013 8:01 PM (UTC-05)
Time ended:   1 Feb 2013 8:04 PM (UTC-05)


I need to send you a file of the base monitor log as this has been going on for many months without resolution.

The hosting company's Windows experts have changed what I believe is the packet authentication to public as we had seen a number of security messages and rebooted each node.

I ran the WMI Test and have 160 Win32_Service objects.

As I said, the issue is INTERMITTENT. I caught the log file this time. I'd like to upload it so your experts can see what's up as I'd like to have a reliable monitor, please...
Last edited by PDinCA on Fri Mar 22, 2013 9:39 pm, edited 1 time in total.
PDinCA
 
Posts: 516
Joined: Mon Jul 25, 2005 11:42 pm
Location: Costa Mesa, CA, USA

Postby chriskelly » Mon Feb 04, 2013 6:12 pm

Please can you gather the SQL Monitor error logs (as per the link below and ensuring that they cover the period of the error) and confirm the following details:

- version of Windows and SQL Server for the machine you are trying to monitor (full version numbers please).
- did you run the WMI test on the Base Monitor host machine and connect to the machine you are trying to monitor?

http://www.red-gate.com/supportcenter/c ... M_LogFiles

Please send to support@red-gate.com and include the support ticket number F0069194 in the subject line.

We can then try to investigate.
Chris Kelly
Technical Support Engineer
chriskelly
 
Posts: 330
Joined: Mon Apr 19, 2010 1:44 pm
Location: Cambridge, UK

Postby PDinCA » Mon Feb 04, 2013 6:49 pm

Email sent, thanks, Chris.
PDinCA
 
Posts: 516
Joined: Mon Jul 25, 2005 11:42 pm
Location: Costa Mesa, CA, USA

Postby PDinCA » Mon Mar 18, 2013 5:43 pm

A Rackspace technician suggested the following, which has completely cleared the issue: "To rule DNS out as a cause of the problem, I would like to edit the host file on this server with the short and FQDN entries for the cluster nodes and devices to see if this either solves the problem or excludes DNS from our troubleshooting."

Case closed!
PDinCA
 
Posts: 516
Joined: Mon Jul 25, 2005 11:42 pm
Location: Costa Mesa, CA, USA


Return to SQL Monitor 3

Who is online

Users browsing this forum: No registered users and 0 guests