V1.1.0 Seems to have broken teamcity nuget.

Automated deployment for web applications and databases

Moderators: Mike Upton, justin.caldicott, Sean.newham, csmith, chirayu, DavidSimner, david.conlin

V1.1.0 Seems to have broken teamcity nuget.

Postby ktersius » Wed Mar 13, 2013 3:21 pm

This new version seems to break the publishing to the teamcity nuget server. It successfully publishes the database package to the server, but then gets an exception and fails the build. If you go to the deployment manager and search for the new package it was published. This was all working fine on the previous release and only broke after we upgraded.

Also I had to delete the newly added built in nuget repository or else my builds failed because the build step was looking for the generated package under this repository and was not finding it.
" Searching for database package MyPackage version 0.22.31.6706 failed with error InvalidOperationException "

Running Teamcity 7.1.3 upgraded to 7.1.4 and same issue.

[Publishing database package MyPackage version 0.22.30.6705 to http://192.168.2.61:8082/guestAuth/app/ ... ervice.svc] ##teamcity[buildStatus status='FAILURE' text='Publishing database package MyPackage version 0.22.30.6705 to http://192.168.2.61:8082/guestAuth/app/ ... ervice.svc failed with error InvalidOperationException']
ktersius
 
Posts: 10
Joined: Thu Mar 07, 2013 8:16 am

Postby chirayu » Wed Mar 13, 2013 4:38 pm

You need to update our TeamCity sqlCI plugin to be able to build database packages via TeamCity.

The latest version can be found here.

Let me know if that fixes the issue. Thanks!
Chirayu Shishodiya
Software Engineer - Deployment Manager
Red Gate
chirayu
 
Posts: 65
Joined: Mon Sep 17, 2012 5:48 pm

Postby ktersius » Wed Mar 13, 2013 5:16 pm

Hi

I did upgrade it today. So it does not seem to be that.

My plugin version is 1.0.0.1003

Thanks
ktersius
 
Posts: 10
Joined: Thu Mar 07, 2013 8:16 am

Postby chirayu » Wed Mar 13, 2013 6:15 pm

Would you please pass a stack trace of the exception?

Also, what version is your Deployment Manager server?

Thanks!
Chirayu Shishodiya
Software Engineer - Deployment Manager
Red Gate
chirayu
 
Posts: 65
Joined: Mon Sep 17, 2012 5:48 pm

Postby ktersius » Thu Mar 14, 2013 8:48 am

Figured out that it was the teamcity redgate plugin that broke it. Downgraded to an earlier version and this resolved the problem.

Please let the CI team know that their latest release is buggy.
ktersius
 
Posts: 10
Joined: Thu Mar 07, 2013 8:16 am

Postby swinghouse » Sun Mar 17, 2013 8:24 pm

I can confirm this bug in the latest version of the CI plugin. :(

/Mattias
swinghouse
 
Posts: 99
Joined: Mon Sep 12, 2011 10:51 am

Postby Andy Morris » Mon Mar 18, 2013 11:52 am

We are working on a solution to this right now.
Thanks for your patience.

Andy Morris
UX Specialist- Deployment Manager
Red Gate
Andy Morris
 
Posts: 4
Joined: Mon Oct 08, 2012 10:44 am

Postby Andy Morris » Mon Mar 18, 2013 3:16 pm

The fixes are now available on the Red Gate website at http://www.red-gate.com/products/sql-development/automation-license-for-continuous-integration/free-resources

The latest versions are available:

- TeamCity plugin v1.0.0.1029
- SqlCI v1.0.0.926

Thanks for your patience.
Best regards,

Andy Morris
UX Specialist- Deployment Manager
Red Gate
Andy Morris
 
Posts: 4
Joined: Mon Oct 08, 2012 10:44 am

Postby swinghouse » Mon Mar 18, 2013 4:00 pm

I just upgraded to v1.0.0.1029 of the TeamCity plugin, but unfortunately the result was the same as before.

This is the error message I get:

Searching for database package BagheraData version 0.20 failed with error InvalidOperationException


I've restarted TeamCity and Deployment Manager.

Deployment Manager version: 1.1.2.1

/Mattias
swinghouse
 
Posts: 99
Joined: Mon Sep 12, 2011 10:51 am

Postby DavidSimner » Tue Mar 19, 2013 11:10 am

Hi Mattias,

For your most recent error where the package version 0.20 for the package named BagheraData can't be found:

Yeh, that's our bad. It was caused because as of the most recent release of Deployment Manager it now has an embedded NuGet package feed, and we haven't yet done the work to make sqlCI compatible with it.

I'm going to get one of the developers to look into this urgently.

Detailed explanation:
To generate static upgrade scripts, sqlCI uses the DM API to ask which versions of the package are currently deployed to any environment in any project, and it then generates static upgrade scripts for those versions. To do this, it contacts the NuGet package feed to download those versions of the package in order to calculate the script.

The problem is that sqlCI only downloads packages from the first NuGet feed in DM no matter how many you have, and the embedded NuGet feed is always set to be the first one. What this means is that it tries to download the old version of the package from the wrong feed causing the error. We'll fix this in 2 ways:
1. We'll contact all the feeds in parallel.
2. We'll turn the package not being there into a warning rather than a build failure, since in the general case it might be an ancient version that got deleted from the NuGet feed, e.g. because TeamCity cleans up old versions after a while (depending on how you've configured it).

David

(internal reference numbers:
sareport://639e5b7e-aea9-4eec-a1cc-4c43c5b72fbe
sareport://af52eaa7-f49a-4bc1-9f4a-309076d1d53d
sareport://5b4bb6f8-0831-42cb-89cf-157e8dbd968a
)
DavidSimner
 
Posts: 49
Joined: Thu Feb 04, 2010 6:05 pm

Postby swinghouse » Tue Mar 19, 2013 12:16 pm

Hi David,

Thanks for the explanation - most appreciated!

I look forward to the bug fix.

/Mattias
swinghouse
 
Posts: 99
Joined: Mon Sep 12, 2011 10:51 am

Postby Andy Morris » Tue Mar 19, 2013 7:54 pm

There is a temporary work around available for the later problem. As David suggested it is caused by the presence of the Deployment Manager package feed in version 1.1.0.27 if you already had an existing feed.

You can work around this problem by deleting this new feed. You can do this as follows:

1. In Settings > Package Feeds delete the Deployment Manager package feed. This is the embedded feed that was added in v1.1.

2. In the Server tools application (Start > Red Gate > Deployment Manager > Server Tools) uncheck "enable deployment manager package feed".

Regards,

Andy Morris
UX Specialist - Deployment Manager
Andy Morris
 
Posts: 4
Joined: Mon Oct 08, 2012 10:44 am

Postby csmith » Wed Mar 27, 2013 7:39 pm

Hi

Just wanted to update this thread to let you know that we believe the problems detailed in David Simner's last post should be fixed in the latest version of SQLCI (v1.0.0.945) and the TeamCity Plugin (v1.0.0.1039).

You can download them from here.

Best regards,
Chris
Chris Smith
Project Manager
Deployment Manager
csmith
 
Posts: 117
Joined: Thu Jun 30, 2011 2:15 pm
Location: Cambridge


Return to Deployment Manager

Who is online

Users browsing this forum: akhilgarg81 and 0 guests