Redgate Backup - Won't Delete All Files Before Backing Up

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

Redgate Backup - Won't Delete All Files Before Backing Up

Postby JoshDBGuy » Mon Feb 18, 2013 8:24 pm

I am running backups to a location with limited storage. Because these backups aren't exactly critical, I only need one backup file. I am setting the program to run and delete existing backup files except for the latest \"1\" and also with \"delete prior to start of backup\" enabled. However, when I run this, it keeps the last backup and causing space issues on the drive. How can I change the program to delete all backup files before the program runs? Can i change the step in the job within sql and set it to 0b instead of 1b?

Thanks
JoshDBGuy
 
Posts: 8
Joined: Fri Jan 04, 2013 7:00 pm

provide code

Postby epetro » Mon Feb 18, 2013 8:56 pm

I think you will get more assistance if you provide the code you are currently running.
You can adjust database/server names for confidentiality.

I know we had an issue with this some time back, but in recent versions no problems.

Be sure to pay attention to any TAPE backup that may be picking up(locking) the previously created file.
You should be able to rename the file as a test to see if it is locked.
epetro
 
Posts: 55
Joined: Tue May 31, 2011 7:55 pm
Location: Zotec Partners

Postby JoshDBGuy » Mon Feb 18, 2013 10:46 pm

Sure, below is the code,

DECLARE @exitcode int
DECLARE @sqlerrorcode int
EXECUTE master..sqlbackup '-SQL \"BACKUP DATABASES [DB1,DB2,DB3] TO DISK = ''C:\\Backup\\Full\\<database>\\<AUTO>.sqb'' WITH ERASEFILES_ATSTART = 1b, PASSWORD = ''<ENCRYPTEDPASSWORD>xxxxxxxxxxx</ENCRYPTEDPASSWORD>'', CHECKSUM, DISKRETRYINTERVAL = 30, DISKRETRYCOUNT = 10, KEYSIZE = 256, THREADCOUNT = 23\"', @exitcode OUT, @sqlerrorcode OUT
IF (@exitcode >= 500) OR (@sqlerrorcode <> 0)
BEGIN
RAISERROR ('SQL Backup failed with exit code: %d SQL error code: %d', 16, 1, @exitcode, @sqlerrorcode)
END




I also double checked and no tape backups are running or did run at the same time.
JoshDBGuy
 
Posts: 8
Joined: Fri Jan 04, 2013 7:00 pm

erasefiles_atstart values

Postby epetro » Tue Feb 19, 2013 4:30 pm

We use the erasefiles_atstart option with a value of 40h.
This assumes we are running a daily backup (every 24 hours) and wish to always have at least 1 complete backup available on disk.

If you wish to essentially overwrite the previous backup you can simply set this value to less than your expected backup schedule.

So if you are running a daily backup, try
Code: Select all
erasefiles_atstart = 1h
epetro
 
Posts: 55
Joined: Tue May 31, 2011 7:55 pm
Location: Zotec Partners

Postby JoshDBGuy » Tue Feb 19, 2013 5:19 pm

Thanks epetro, I thought of something like that too. It's not super clean but it should work for our office.
JoshDBGuy
 
Posts: 8
Joined: Fri Jan 04, 2013 7:00 pm


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 2 guests