Error generating HTML report in Command Line

Compares and synchronizes SQL Server databases, backups and scripts.

Moderators: JonathanWatts, Chris Auckland, David Atkinson, eddie davis, Anu Deshpande, Michelle Taylor, alice.easey, james.billings, chengvoon.tong

Error generating HTML report in Command Line

Postby espo4life » Wed Oct 31, 2012 6:51 pm

I am using SQL Compare 10 with the following command line

Code: Select all
SQLCompare /Scripts1:"C:\\Database" /db2:"Database" /Server2:"Server" /ScriptFile:"C:\\Database\\output.sql" /Force /Exclude:User /Report:"c:\\Database\\DatabaseReport.html" /ReportType:Simple


and it gives me the following with the /Report tag present.

Code: Select all
Unexpected error: Object reference not set to an instance of an object.
Object reference not set to an instance of an object.
System.NullReferenceException
   at #i9G.#wamb.#0CIc()
   at #i9G.#wamb.#jcmb()
   at #i9G.#wamb.#9OVb()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#ZjD()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#kcmb()
   at #i9G.#wamb.#kcmb()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#OUb()
   at #i9G.#OsPb.#6sc(String[] #ead)

Any ideas on the problem and how to fix it?

Thanks,
Michael
espo4life
 
Posts: 2
Joined: Wed Oct 31, 2012 6:46 pm

Postby Brian Donahue » Thu Nov 01, 2012 10:25 am

Can you try appending /Include:Identical to the command?
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby sddesh » Thu Dec 13, 2012 11:54 pm

Did you find an answer to this issue? Having the same problem. Thanks.
sddesh
 
Posts: 2
Joined: Thu Dec 13, 2012 11:30 pm

Postby Brian Donahue » Fri Dec 14, 2012 10:39 am

Nope. No solution and can't reproduce it in-house.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby sddesh » Tue Dec 18, 2012 11:01 pm

SqlCompare /S1:server1 /db1:database1 /S2:server2 /db2:database2 /Exclude:Schema /Exclude:User /Exclude:Role /Options:Default,IgnoreComments,IgnorePermissions,IgnoreFillFactor,IgnoreWhiteSpace,IgnoreQuotedIdentifiersAndAnsiNullSettings,IgnoreExtendedProperties,IgnoreWithNocheck,IgnoreConstraintNames /report:"C:\\test.xml" /reporttype:XML /force /loglevel:verbose

gives the above mentioned "object reference not set to instance of object error". Could you please look at it? Am I doing anything wrong here? This is working when I send the output to a text file using /out: variable (without report generation). But erroring while trying to do a report.
sddesh
 
Posts: 2
Joined: Thu Dec 13, 2012 11:30 pm

Postby Brian Donahue » Wed Dec 19, 2012 11:40 am

Please contact support at red-gate.com by email. We'll probably need to debug the program with you.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am


Return to SQL Compare 10

Who is online

Users browsing this forum: No registered users and 0 guests