Unable to link to TFS 2012

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Moderators: Chris Auckland, David Atkinson, Paul Stephenson, sherr, PhilScrace, andy.campbell.smith

Unable to link to TFS 2012

Postby Jeff9000 » Sat Dec 15, 2012 6:02 pm

I believe that I am running the latest version of Source Control. Is there somewhere that I can see the version?

UPDATE: I found the version and I found the Update and updated to Source Control 3.1.

Furthermore, I edited the XML Config file:

<?xml version=\"1.0\" encoding=\"utf-16\" standalone=\"yes\"?>
<!---->
<EngineOptions version=\"3\" type=\"EngineOptions\">
<TeamFoundationServerDllOverride>RedGate.SQLSourceControl.Engine.SrcC.TFS2012</TeamFoundationServerDllOverride>
</EngineOptions>

But, I'm still getting the following error when I try to link to a TFS collection named Database.

The link error is:

The folder may not exist, or the path may be typed incorrectly. SQL Source Control can create a new folder in a Team Project, but to create a new top level folder you must create a new Team Project using Team Explorer.

My Server Url is: http://ntfs01:8080/tfs/Database or I've tried it as http://ntfs01:8080/tfs

My Database folder is either $/JohnsHopkins/ or $/Database/JohnsHopkins.

When I click the Browse button to the right of the Database folder it shows the TFS server, but the Create Folder button is disabled.

The database I'm trying to link is in a SQL2008 R2 server.

Please help.

Thanks
Jeff9000
 
Posts: 5
Joined: Sat Dec 15, 2012 5:53 pm

Making progress, but still won't link

Postby Jeff9000 » Sun Dec 16, 2012 6:50 pm

I'm creating a Project (\"Test\") in my Database collection in VS2012 after installing Team Foundation for VS2012 from MS.

But, the error message I get when I link is:

\"The Path must be an empty folder.\"

But, when I create the Project in VS2012 it adds a folder and files and I can't control that and I am unable to delete the files and folder.
Jeff9000
 
Posts: 5
Joined: Sat Dec 15, 2012 5:53 pm

Nevermind, I think I figured it out

Postby Jeff9000 » Sun Dec 16, 2012 8:21 pm

Wow, what pain.

In TFS 2012 you need to add Collections in the TFS Admin app on the machine TFS is installed on.

Then you need to add Projects to a Collectionusing VS2012, but to get that Create Project menu item you need to first disconnect from TFS and then re-connection while unchecking all the Project checkboxes.

To Delete projects you need to use, again, the TFS Admin app.

Now, you need to go into SSMS in the Red-Gate select folder/create folder you need to navigate to the Project you created in VS2012 and then create a folder (ie. Schema) and another folder for Migrations.

So, it's one stop shopping!
Jeff9000
 
Posts: 5
Joined: Sat Dec 15, 2012 5:53 pm

I'm sorry, but your response is useless

Postby Jeff9000 » Tue Jan 22, 2013 6:56 pm

I'm very disappointed in Red Gate.

I posted my first post back in December 15, 2012 and someone from Red Gate is finally replying on January 21, 2013 - more than a month later.

Worse, if you read my posts carefully you will notice that none of my folder names have an underscore. And your response is about a bug in your product relating to underscores.

Sorry!!! But you missed the boat.

Wow!
Jeff9000
 
Posts: 5
Joined: Sat Dec 15, 2012 5:53 pm

Postby Chris Auckland » Wed Jan 23, 2013 11:20 am

Sorry for the delay.

We usually have a notification service running to alert the support team to any unanswered posts, but that went down temporarily just before Christmas and it looks like your post was affected.

It also looks like a spammer responded quite convincingly to your post with some completely unrelated advice, presumably taken from somewhere else on our forums. I'll delete that to prevent further confusion.

I hope you accept our apologies on both incidents.

With regards to your actual issue you're experiencing, I assume that you can connect to the collection through VS on the same machine as you're using SSMS. If that's ok, then I have seen this kind of thing happen when there is something wrong with the config file. Normally some whitespace causing the config to be ignored.

If you're still having a problem linking SQL Source Control to TFS preview, then could you email support@red-gate.com along with your config file and we'll try and troubleshoot the problem for you?

You might also like to try using SQL Connect instead, as this will enable you to work with TFS and your database from within VS, rather than SSMS.

Again, sorry for the slow response.
Chris
Chris Auckland
 
Posts: 757
Joined: Tue Oct 24, 2006 2:12 pm
Location: Red Gate Software Ltd.

Thanks, Chris

Postby Jeff9000 » Wed Jan 23, 2013 8:37 pm

I did manage to figure out hooking up Red Gate with Team Foundation.

Thanks!
Jeff9000
 
Posts: 5
Joined: Sat Dec 15, 2012 5:53 pm


Return to SQL Source Control 3

Who is online

Users browsing this forum: No registered users and 0 guests