Problems with string and path also without obfuscation

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Problems with string and path also without obfuscation

Postby MarkCEO » Tue Nov 27, 2012 12:03 am

Good evening, i'm new, i'm trying SmartAssembly to protect my software, i tried also without all obfuscations and etc.. disabled but just with rebuilding the application through SmartAssembly i have few exceptions and i don't know why; all these exceptions concern strings and paths.

for example:

EXCEPTION:

Value cannot be null.
paths -> in System.IO.Path.Combine(String[] paths) in PokerDream.Client.Data.SQLiteDatabaseHelper.GetConnectionString(String connStr)

METHOD:
private string GetConnectionString(string connStr)
{
try
{
var dir = Path.GetDirectoryName(connStr);
var file = Path.GetFileName(connStr);
return System.IO.Path.Combine(Environment.GetFolderPath(Environment.SpecialFolder.LocalApplicationData), "XXX", "XXX Client", dir, file);
}
catch (Exception ex)
{
Logger.Log(Logger.LogType.ERROR, ex);
}
return string.Empty;
}

EXCEPTION:
Invalid path format
in System.IO.Path.NormalizePath(String path, Boolean fullCheck, Int32 maxPathLength)
in System.IO.Path.GetDirectoryName(String path)
in PokerDream.Client.Data.SQLiteDatabaseHelper.CreateDB()

METHOD:
var dir = Path.GetDirectoryName(connectionString);

and another similar problem.

I have also problems with webservices.

Thanks in advance.
MarkCEO
 
Posts: 2
Joined: Mon Nov 26, 2012 11:53 pm

Postby Chris.Allen » Wed Nov 28, 2012 1:41 pm

Hello. I'm old but I know a thing or two about Smartassembly ;)

I'm a bit confused about what exactly led up to those errors you got as i don't recognise them as Smartassembly errors- they even look more like compiler errors.

Can I just check- your application compiles and runs perfectly well unobfuscated?

When you build a smartassembly project- with no features selected at all- you get the errors you mention?
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Re:

Postby MarkCEO » Fri Nov 30, 2012 3:28 pm

Chris.Allen wrote:Hello. I'm old but I know a thing or two about Smartassembly ;)

I'm a bit confused about what exactly led up to those errors you got as i don't recognise them as Smartassembly errors- they even look more like compiler errors.

Can I just check- your application compiles and runs perfectly well unobfuscated?

When you build a smartassembly project- with no features selected at all- you get the errors you mention?


yes works perfectly
MarkCEO
 
Posts: 2
Joined: Mon Nov 26, 2012 11:53 pm

Postby Chris.Allen » Mon Dec 10, 2012 8:45 pm

I tried to reproduce but had no luck in forcing any kind of error.
This is not a known error so please treat this like a undifferentiated bug in code and can you track down where in the code it actually behaves differently to non-protected code? For example, it looks like the path string is not initialized so if we can track down why we should be closer to diagnosis.

Sorry I cannot be more specific.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Postby eric-914 » Mon Dec 10, 2012 8:47 pm

When you try to run the obfuscated version, does the .config file exist in the same folder as the .exe?

This has caught me a few times.
eric-914
 
Posts: 28
Joined: Fri Nov 30, 2012 5:51 pm

Postby Chris.Allen » Tue Dec 11, 2012 9:25 pm

Ah! Well done eric-914- this could well be the issue. Smartassembly has no effect on the .config file - which means it won't copy it over for you either so this could be the exact problem.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests