Bug: Must declare the scalar variable \"@pv\"Possible Solution

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings, Marianne

Bug: Must declare the scalar variable \"@pv\"Possible Solution

Postby vasper » Fri Mar 30, 2012 2:53 pm

This was not fixed despite being said so in the maintenance release. Now in fact it is the oposite. Varialbe NOT declared!!!!

The problem seems to be associated with the declaration that is missing from the batch scope.

Image

I am 99% sure that this \"Batch13\" is executed out of scope.

This happens a lot in our scripts since they contain large number of binary data updates.

You should insert the declaration dynamicaly when the exes are running the scripts, right after the first batch.
vasper
 
Posts: 6
Joined: Fri Mar 30, 2012 1:16 pm

Postby Brian Donahue » Mon Apr 02, 2012 3:56 pm

I believe you may have come across a message in a different forum. The problem was fixed in SQL Data Compare v9, however because Packager development lags behind the rest of the SQL tools, the SQL Data Compare DLL in SQL Packager is still version 8.50.

I'll send you a link via private message to a patched version of SQL Packager that uses the new DLL. I don't know if this build is ready for public release yet, but you're welcome to try it.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby vasper » Mon Apr 02, 2012 5:14 pm

Thank you for your quick reply, but I tried it and it didn't work. I get the exact same error.

Must declare the scalar variable \"@pv\".
Must declare the scalar variable \"@pv\".

SQLPackageMAPSD2Store1

Package13.resx

Batch9



As I said, I generate the script and package it inside an exe using only sql packager. The resulting exe I run against the database that needs update.

Version is 6.6.0.347
vasper
 
Posts: 6
Joined: Fri Mar 30, 2012 1:16 pm

Postby Brian Donahue » Mon Apr 02, 2012 5:46 pm

Ok, sorry we have not got a fix at this time.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby Brian Donahue » Mon Apr 02, 2012 5:48 pm

Just to make sure - you are not setting the maximum data transaction size option?
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby vasper » Mon Apr 02, 2012 7:38 pm

Nope...
vasper
 
Posts: 6
Joined: Fri Mar 30, 2012 1:16 pm

Postby Brian Donahue » Tue Apr 03, 2012 9:12 am

I have logged a bug for this (SPA-589).
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby vasper » Thu Nov 01, 2012 11:24 am

Any news on this? Please, I loose 1 to 2 working days every time I create an update. We do this procedure at least 4 times a year.
vasper
 
Posts: 6
Joined: Fri Mar 30, 2012 1:16 pm

Postby Brian Donahue » Thu Nov 01, 2012 11:28 am

There is no update to this issue.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby vasper » Mon Nov 19, 2012 4:13 pm

It is creating a real problem for me due to the size of data I have to upgrade.

Can you at least give me an ETA? Otherwise I will have to look for a different solution.
vasper
 
Posts: 6
Joined: Fri Mar 30, 2012 1:16 pm


Return to SQL Packager 6

Who is online

Users browsing this forum: No registered users and 0 guests