Error when restoring .sqb file

SQL Virtual Restore: Rapidly mount live, fully functional databases direct from backups

Moderators: eddie davis, Colin Millerchip, fionag

Error when restoring .sqb file

Postby lee.walters » Mon Oct 01, 2012 12:18 pm

Have been trying to restore a .sqb file to a Virtual database but every time I do it returns an error at the end saying that the Media is incorrectly formed.

It only ever happens with this one database backup. i.e. I have tried several times to backup the file and restore it.

It works with other backups of other databases. I'm just wondering if there is a size limitation? the DB backup (.sqb) file is around 90Gb in size. The Physical database is around 800GB on disk

Any help or pointers would help

Thanks
--== Nothing is fool proof, to a talented fool ==--
Lee Walters
lee.walters
 
Posts: 3
Joined: Wed Jul 18, 2012 11:46 am

Postby peter.peart » Thu Oct 04, 2012 9:52 am

Thanks for your post. There isn't a size limitation, but there's a couple of things that *could* be causing the problem. These are:

- The backup file is corrupt
- You're performing a virtual restore over the network (backup file located on another machine) and you're getting data loss or there's connectivity problems.

Have you actually been able to restore this file properly?
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
peter.peart
Site Admin
 
Posts: 362
Joined: Tue Sep 02, 2008 9:58 am
Location: Top floor, RG towers with the cool kids

Postby lee.walters » Thu Oct 04, 2012 10:39 am

Hi Peter

Thanks for the reply.

I've done a verify of the backup file on the server where the backup was taken and that was OK - copied the file to the server that's hosting the new database - so we're not restoring over the network.

I'll try copying the file again though using RoboCopy to ensure that the file copy operation hasn't timed out and revert with the results.

Thanks

Lee Walters
--== Nothing is fool proof, to a talented fool ==--
Lee Walters
lee.walters
 
Posts: 3
Joined: Wed Jul 18, 2012 11:46 am

Postby maithly » Thu Feb 06, 2014 5:43 am

The HyperBac service is set to login with an admin level account for testing purposes. The folder was opened to the Everyone role. Neither of these cause a change in the error.
MAITHLY
maithly
 
Posts: 1
Joined: Thu Feb 06, 2014 5:28 am


Return to SQL Virtual Restore 2

Who is online

Users browsing this forum: No registered users and 0 guests