SQL backup 7.0 - There is already a copy of sql backup runni

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

SQL backup 7.0 - There is already a copy of sql backup runni

Postby murali.tal@aztec.com.au » Fri Sep 07, 2012 5:50 am

I recently purchased the reg gate licenses and after the instalaltion i was getting this message when i tried to opened it "There is already a copy of SQL Backup running on this computer".

This is the first time i installed on a server.

Do any one come acrross this problem? Please help
murali.tal@aztec.com.au
 
Posts: 2
Joined: Fri Sep 07, 2012 5:44 am
Location: Sydney

Postby Brian Donahue » Fri Sep 07, 2012 9:21 am

Hello,

I've seen this one a few times - it's caused by the existence of a "lockfile" on the client-side activity history database that the SQL Backup Console uses. Since you can only have one console per user session, it assumes that if there is a lockfile present, the user is already running SQL Backup Console.

Please check %userprofile%\\appdata\\local\\red gate\\sql backup for a file called lockfile.pid. If it exists, delete it or check that it is not being locked by an anti-virus scan. If not, ensure you have full rights to the folder.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby murali.tal@aztec.com.au » Tue Sep 11, 2012 1:29 am

Thanks for the post.

There isn't any file named lockfile.pid in the location %userprofile%\\appdata\\local\\red gate\\sql backup. I checked with system administrator that anti virus isn't blocking.

When i looked at the task manager-->processes i can see that the redgate bakcup GUI is running in the background. After i killed the process i can able to open the redgate GUI.

Wasn't sure why it didn't stop the processes when i close the GUI. Is there a permission issue? But i was able to kill the redgate process using the same login.
murali.tal@aztec.com.au
 
Posts: 2
Joined: Fri Sep 07, 2012 5:44 am
Location: Sydney

Postby Brian Donahue » Tue Sep 11, 2012 10:10 am

Sorry, I can't determine the cause of this. There must have been a worker thread running that did not terminate when you closed the window. If this happens again, we can try attaching a debugger and getting a stack dump to try to see what it's doing.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby Randy Doub » Thu Sep 13, 2012 9:55 pm

You'll find this happens fairly often. Task Manager > End Process and restart the gui.
Randy Doub
 
Posts: 19
Joined: Mon Jan 28, 2008 5:08 pm

Postby Brian Donahue » Fri Sep 14, 2012 9:15 am

This never happens to me, unfortunately. If it happens again, please try this:
  • download ftp://support.red-gate.com/utilities/re ... bugger.zip
  • Extract and run redflag-x86
  • Use Actions->attach process and attach to RedGate.SQLBackup.ui.exe
  • Use actions->dump stacks
  • Copy the window content (click in it and CTRL-c)
  • Close window
  • Actions->detach process
  • Paste results into a forum reply


I should be able to interpret this and at least tell you what backup is doing.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby meklembl » Mon Sep 17, 2012 3:36 pm

Intermittently, this occurs on my client PC as well. Thanks for the process to use to report this. I have normally just killed the RedGate.SQLBackup.UI process on my PC and everything works.
Larry M
Cleveland, OH USA
meklembl
 
Posts: 93
Joined: Fri Aug 24, 2007 3:08 pm
Location: Solon, OH, USA

Postby meklembl » Mon Sep 17, 2012 3:39 pm

Also, I cannot say for sure, but this happens to me when I use the Windows "X" to close the program on my PC and is less likely to occur when I use the menu File/Exit process.
Larry M
Cleveland, OH USA
meklembl
 
Posts: 93
Joined: Fri Aug 24, 2007 3:08 pm
Location: Solon, OH, USA

Postby rre » Mon Oct 01, 2012 8:59 am

This happens also for me from time to time. Sometimes I used window "X" button, sometimes the shortcut ALT + F4 or the Exit item from the File menu.
I can't say for sure with which way the problem occur for now.

To solve it I use the task manager to kill the running process.
rre
 
Posts: 30
Joined: Thu Jul 07, 2011 2:13 pm


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 0 guests