Trial Version 7:Attaching to other servers to do restores...

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

Trial Version 7:Attaching to other servers to do restores...

Postby SQL_ME_RICH » Fri Jun 01, 2012 10:37 pm

Is the trail version of SQL Backup 7 able to connect to other servers when browsing the file system for backup files? I have large backup files (even with compression) on other servers that I need to use to restore those databases on yet another server.

Every time I try to attach to a server, it lets me, but when I navigate to the area I need to use a backup file from, I get errors making it seem like the file is not there.

Any thoughts would be most appreciated.
SQL_ME_RICH
 
Posts: 64
Joined: Tue May 08, 2012 10:41 pm

Postby andy.campbell.smith » Mon Jun 04, 2012 12:54 pm

Due to the way SQL Backup handles credentials for viewing files on other servers, there are a few known issues where remote browsing doesn't work properly. Without knowing more about your specific issue, it's hard to say exactly what it is, but it's probably one of the two following issues:

http://www.red-gate.com/supportcenter/c ... 0903000369

http://www.red-gate.com/supportcenter/C ... 000417.htm

Let me know if either of those articles helps at all!
Andy Campbell Smith

Red Gate Technical Support Engineer
andy.campbell.smith
 
Posts: 173
Joined: Thu Oct 20, 2011 11:19 am
Location: Red Gate Software

Postby SQL_ME_RICH » Mon Jun 04, 2012 6:29 pm

Andy - thank you for getting back to me on this. I have looked at the links you provided, but I probably need to be more specific here. It's not that in the process of doing a restore that I cannot add files from another server's share, but once I do - I get the Red X and type Unknown, and file name leading with 'Unavailable' in Red text.

Here is a snapshot for you...
Image


I am hoping that my windows login will suffice to resolve this, because I do not have a lot of flexibility here. It's the same login for all the various boxes with the same credentials on each, but as you can see - no joy in getting to the files.

Any help would be appreciated.
SQL_ME_RICH
 
Posts: 64
Joined: Tue May 08, 2012 10:41 pm

Postby andy.campbell.smith » Thu Jun 07, 2012 3:18 pm

Hmm. I'd guess this was a permissions problem - the account that's running the SQL Backup Agent service on the server you're trying to run the restore on needs to have read permissions on the folder containing the backup file.

Can you confirm that the account running the SQL Backup Agent service has the appropriate permissions? You can check the account running it with the Services utility in Windows - it ought to show up as "SQL Backup Agent-<instancename>". If you right-click it and select 'Properties', you can change the account it logs on as.
Andy Campbell Smith

Red Gate Technical Support Engineer
andy.campbell.smith
 
Posts: 173
Joined: Thu Oct 20, 2011 11:19 am
Location: Red Gate Software

Postby PDinCA » Fri Jul 06, 2012 12:14 am

I had the same problem!

Took a hammer to it and added the Service Account to the Local Admin Group and rebooted the server!

Works now 8)
PDinCA
 
Posts: 512
Joined: Mon Jul 25, 2005 11:42 pm
Location: Costa Mesa, CA, USA


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 0 guests