Nothing happends running against a .exe

Code profiling for .NET developers.

Moderators: AndrewH, melvyn.harbour, james.billings, Laura Morley, dene.boulton

Nothing happends running against a .exe

Postby staggerlee011 » Wed Jul 04, 2012 11:12 am

Hi,

im trying to look at the performance of a .net app we have that runs off a .exe

typically the users connect via a shortcut that links to a exe on the server.

If i try and run a ANTS Per on it .. the application will load up. But when i clikc around the GUi nothing shows up in the

But using say processes explorer i can see network requests and io going on.

Any ideas on what im missing to get it reporting? for me...
staggerlee011
 
Posts: 9
Joined: Tue Jan 17, 2012 5:59 pm

Postby Chris.Allen » Thu Jul 05, 2012 12:32 pm

I can suggest some workarounds- is this, by any chance, a .Net 4 exe?

If so- try the "attach-to-process" or "sampling" mode of profiling.

My guess is that ANTS is profiling the wrong process so "attach-to-process" is your best chance of profiling the correct process.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm

Postby staggerlee011 » Thu Jul 05, 2012 12:36 pm

Hi

and thanks for the reply..

Im afraid im a complete novice on this.. How would i tell which version is uses?

Where could i make the suggestions you said? I cant seem to find them..
staggerlee011
 
Posts: 9
Joined: Tue Jan 17, 2012 5:59 pm

Postby Chris.Allen » Mon Jul 09, 2012 11:59 am

I guess it might be quickest to ask the person who created the application- they will know if its .Net 4 or not.

The profiling options are on the profiling setup screen that ANTS presents before you start profiling. Look for the 'Profiling mode' drop down.
Chris.Allen
 
Posts: 594
Joined: Thu Mar 12, 2009 4:17 pm


Return to ANTS Performance Profiler 7

Who is online

Users browsing this forum: No registered users and 0 guests