Extended properties not retrieved correctly in ver 2.1.0.220

Documents SQL Server 2005 and 2008 databases.

Moderators: JonathanWatts, David Atkinson, Michelle Taylor

Extended properties not retrieved correctly in ver 2.1.0.220

Postby nharris » Wed Oct 05, 2011 12:22 pm

Having just installed SQL Docs version 2.1.0.220, I have found that the descriptions of tables and their columns are not retrieved from the database but are all shown as "RedGate.SQLCompare.Engine.ExtendedPropertyValue".
nharris
 
Posts: 4
Joined: Wed Oct 05, 2011 12:07 pm

Postby james.billings » Wed Oct 05, 2011 5:43 pm

Thanks for posting this - I've just checked this myself and it seems you're correct. I'll go check with the developers as to what's happened here.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby james.billings » Wed Oct 05, 2011 8:39 pm

Just an update on this - we should have a new build available tomorrow to resolved this. I'l update this post once it's live.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby cpdm » Thu Oct 06, 2011 2:42 pm

Yes, I've had this error too in SQLDoc2. I checked this morning and there was no update yet. I'm looking forward to the post that the fix is available.
cpdm
 
Posts: 1
Joined: Thu Oct 06, 2011 2:41 pm

Postby james.billings » Thu Oct 06, 2011 3:09 pm

The fix for this should now be available if you "Check for Updates" again. Thanks for reporting it!
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby nharris » Thu Oct 06, 2011 5:14 pm

Yes, that seems to have sorted it. Thanks for the quick response!
nharris
 
Posts: 4
Joined: Wed Oct 05, 2011 12:07 pm

Postby lewinuk » Mon Dec 12, 2011 3:23 pm

This issues seems to have reoccurred in version 2.1.0.237
lewinuk
 
Posts: 2
Joined: Mon Dec 12, 2011 3:08 pm

Postby james.billings » Mon Dec 12, 2011 3:28 pm

Could you confirm the object type/level you're observing this at? It may be that it was fixed in one place but missed in another.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby lewinuk » Mon Dec 12, 2011 3:49 pm

I am seeing this when documenting stored procedures.
lewinuk
 
Posts: 2
Joined: Mon Dec 12, 2011 3:08 pm

Postby james.billings » Mon Dec 12, 2011 3:54 pm

OK, I've updated the original bug; hopefully we can get it looked at soon.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Still happening

Postby GaryHampson » Tue Jul 03, 2012 12:57 am

In version 2.1.1.3, this issue is still occurring:

RedGate.SQLCompare.Engine.ExtendedPropertyValue
GaryHampson
 
Posts: 14
Joined: Fri Jan 07, 2005 7:15 pm
Location: New York, NY


Return to SQL Doc 2

Who is online

Users browsing this forum: No registered users and 0 guests