Feature Usage on different assemblies

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Feature Usage on different assemblies

Postby Nicola.Zecchin » Thu Jun 21, 2012 10:44 am

Hi Everybody,

We have a solution composed by a main assembly .exe and many other different assembly .dlls (every one represents a different plugin).
We already implemented the error report on the whole solution and it works pretty good.
Now we want to implement also the feature usage.
So we added some calls in the main assembly .exe code and also in a single specific .dll, just to try.
When enabling the feature usage in the main .exe ('with consent dialog box on first run'), everything works fine for that assembly.
But when enabling the feature usage in the test dll (same Application name, Project name and Company name than the main assembly .exe, same option 'with consent dialog box on first run'), the main assembly .exe keeps on being tracked, while the test assembly .dll does not.

Could you please help us?

Thanks!
Nicola.Zecchin
 
Posts: 2
Joined: Wed Jun 20, 2012 10:00 am
Location: my desk

Postby Nicola.Zecchin » Thu Jun 21, 2012 10:49 am

Ah, sorry: I forgot to say that we're using SmartAssembly Version 6.2 (build 215)
Nicola.Zecchin
 
Posts: 2
Joined: Wed Jun 20, 2012 10:00 am
Location: my desk

Postby jessica.ramos » Sat Jun 23, 2012 12:22 am

I believe we have a support ticket open for you. I will keep in touch via email. :)
Jessica Ramos
Technical Support
Red Gate Software Ltd.
jessica.ramos
 
Posts: 235
Joined: Mon Apr 23, 2012 1:13 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests