Unable to save information inside GUI's "Server Options"

Compresses, encrypts, secures and monitors SQL Server backups.

Moderators: JonathanWatts, Chris Auckland, eddie davis, Colin Millerchip, Brian Harris, james.billings, RBA, petey

Unable to save information inside GUI's "Server Options"

Postby NeM » Fri Jun 08, 2012 4:59 pm

I have updated the GUI to SQL Backup 7.0.6.2 and the server components too. I right-click on the server in the GUI and choose Options. The "Server Options" dialog box comes up. I made changes in there (both File Management and Email settings) and clicked on OK. The settings changes do not remain after clicking on Options again - they revert back to blanks. The sql server 2005 is installed in Windows Server 2003 x64 SP2. The user name set up to run the SQL Backup Agent on the server is a domain service account with full-control permissions for files,folders and sub-folders inside C:\\Documents and Settings\\All Users\\Application Data\\Red Gate\\SQL Backup. I read the help instructions on a older post by Eddie Davis at http://www.red-gate.com/messageboard/vi ... hp?t=15060 but it did not resolve my issue.
NeM
 
Posts: 18
Joined: Mon Feb 14, 2011 4:55 pm

Postby petey » Sat Jun 09, 2012 2:20 pm

Those settings are stored in the registry node

HKLM\\Software\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\<instance name>

on the machine where the SQL Server instance is running on. Try changing the e-mail server name, and see if the value is saved in the above registry node, in the 'SMTPHost' value. If not, please check if the SQL Backup Agent service startup account has rights to read and write to the above registry node.
Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 7
petey
 
Posts: 2226
Joined: Sun Apr 24, 2005 12:34 pm

Postby NeM » Sat Jun 09, 2012 2:58 pm

Thanks for the reply Petey. This is now resolved. It turns out the encrypted password for the SMTP account in the registry at HKLM\\Software\\Red Gate\\SQL Backup\\BackupSettingsGlobal\\<instance name> in the SMTPPassword node was incorrect. It did not work through the GUI when I tried to correct it there but after stopping the SQL Backup agent service and correcting it at that registry node and restarting the service, it did work and the settings information are correctly retained in the GUI.
NeM
 
Posts: 18
Joined: Mon Feb 14, 2011 4:55 pm


Return to SQL Backup 7

Who is online

Users browsing this forum: No registered users and 0 guests