"Summarizing results..." forever

Code profiling for .NET developers.

Moderators: AndrewH, melvyn.harbour, james.billings, Laura Morley, dene.boulton

"Summarizing results..." forever

Postby samid » Thu Mar 08, 2012 12:15 am

Hi,

Today I upgraded from Performance profiler 6.* to 7 (developer bundle, to be exact), and cannot get line-level profiling to work anymore. I am profiling a rather large project, and if I choose line-level profiling (only for my code), run my program and select a region - I get the "Summarizing results" screen that sits there forever (I actually waited 2 hours). Before the upgrade (this morning), profiling the same actions in the same project, the wait time was insignificant (not more than a minute at most). Now it doesn't work at all. The project is a large WinForms .NET 4.0 project running from VS 2010. On a small test project line level profiling seems to work fine but on my real project - no go. Method level profiling works fine. Any ideas?

Thanks.
samid
 
Posts: 4
Joined: Wed Mar 07, 2012 11:25 pm

Postby james.billings » Fri Mar 09, 2012 10:57 am

Thanks for your post and I'm sorry you've run into trouble.
We're interested in establishing what may be happening here. I'm assuming you never actually get to the point of viewing your results, correct? If you do, then we'd like to see those. Failing that, the log file file would be the next step (you can find the option for this on the Help menu) - can you mail this across to support@red-gate.com, quoting F0058203 in the subject line?
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby samid » Fri Mar 09, 2012 3:20 pm

Thanks for replying. You're right, I never get to the point where I could see the results. I have emailed the log to the address you provided, according to it something did go wrong. Let me know if it helps to identify the problem.

Thanks.
samid
 
Posts: 4
Joined: Wed Mar 07, 2012 11:25 pm

Postby james.billings » Fri Mar 09, 2012 3:46 pm

Thanks, I've received the file- will pass it across to the profiler team
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby Laura Morley » Fri Mar 09, 2012 6:07 pm

Thanks for your report, samid, and sorry to hear you're having this problem. We think it may be an example of a bug we have logged, PP-1846 - we're investigating that now. I'll let you know when we have some more news. Thank you.
Laura Morley
 
Posts: 34
Joined: Wed Jun 22, 2011 2:13 pm
Location: Red Gate Software

Postby parlabane » Tue Mar 13, 2012 2:41 pm

I'm also running into this problem. I just spin forever.
parlabane
 
Posts: 1
Joined: Tue Mar 13, 2012 2:35 pm

Postby Brian Donahue » Thu Mar 15, 2012 1:30 pm

There is some sort of bug in ANTS Performance Profiler - if you look at the logs, there is probably something around "Tried to access an out of range method ID". (PP-1846)

Profiler will still work in methods-only mode.

So far, nobody has worked out the cause for this.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby Brian Donahue » Thu Mar 15, 2012 4:02 pm

I've been told that you may be able to get around this problem simply by selecting another area on the timeline. Hopefully that helps.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Re:

Postby samid » Thu Mar 15, 2012 4:52 pm

Brian Donahue wrote:I've been told that you may be able to get around this problem simply by selecting another area on the timeline. Hopefully that helps.


Thanks, that does seem to help.
samid
 
Posts: 4
Joined: Wed Mar 07, 2012 11:25 pm

Postby james.billings » Wed Mar 21, 2012 9:31 pm

If anyone else is experiencing this problem, please try the update available from here.

Please note, this is an untested build intended to correct only the problem described in this thread. If you aren't experiencing this problem then we recommend you don't install this version.

A full fix will be pushed through into Check for Updates in the near future hopefully, and we'll post back when that's available.
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.


Return to ANTS Performance Profiler 7

Who is online

Users browsing this forum: No registered users and 0 guests