Upgrade from SmartAssembly 6.1 to 6.5

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Upgrade from SmartAssembly 6.1 to 6.5

Postby pahunt » Mon Dec 19, 2011 11:00 am

Hi,

We've just upgraded our build server from version 6.1.0.48 to 6.5.2.21 and we now have 2 issues. Nothing has changed in any of the saproj files and if I reinstall version 6.1 then the issues go away.

Firstly, the amount of time it takes to obfuscate our 8 assemblies has increased from just over 2 minutes to just over 5 minutes. This is an ASP.NET MVC application so there a couple of web assemblies but the other 6 are standard .NET dlls.

Secondly, and even more seriously, some pages in our application refuse to load with the following error

Code: Select all
An attempt was made to load a program with an incorrect format


Can someone please give me some advice on what can be done to solve these problems please.
pahunt
 
Posts: 4
Joined: Tue May 26, 2009 11:45 am

Postby james.davies » Tue Dec 20, 2011 2:18 pm

Hi,

Sorry you're having problems with v6.5.

In many cases v6.5 is faster. What features are you using ? Are you merging or embedding large dependencies ?

Can you isolate which SA feature is causing the error in the processed assembly?
(There is a recently fixed bug relating to custom attributes processing which occurs with no features enabled. If that is the case for you , then I can supply a patched version)
Thanks,
James Davies
Technical Support Engineer
Red Gate Software
james.davies
 
Posts: 46
Joined: Tue Apr 19, 2011 2:39 pm

Postby PawelP » Mon Jan 16, 2012 3:07 pm

I have similar problem with increased time.
My dll contains many windows (about 120). Some of them are small (ex. 10 controls), but most of them contains much more then 100 controls and some are very big with more then 1000 controls.
With version 6.0 obfuscation takes 2,5 minutes. With version 6.5 - 9 minutes!
Project settings are: pruning and obfuscating with unicode unprintable characters.
Ask for anything, which can help You find solution for this problem.
PawelP
 
Posts: 3
Joined: Thu Jan 05, 2012 11:57 am
Location: Poland

Postby james.davies » Mon Jan 16, 2012 3:21 pm

Hi,

Firstly I should say that v6.5 is a re-architecture which is why it's performance is very different to v6.2 (in many cases better, but some cases worse).

SmartAssembly 6.6 is a recently released update and contains bug fixes and some memory improvements. v6.6 is a recommended update for all users of SmartAssembly 6.5.

http://www.red-gate.com/supportcenter/C ... rtAssembly

Please give it a try and let me know if there are still performance problems.
Thanks,
James Davies
Technical Support Engineer
Red Gate Software
james.davies
 
Posts: 46
Joined: Tue Apr 19, 2011 2:39 pm

Postby PawelP » Mon Jan 16, 2012 3:29 pm

Ok. I will install 6.6 today and check how it works.

I've checked this version and it isn't better - obfuscation task is taking too long (pruning goes really fast).
I've also noticed, that version 6.6 removes our custom attributes from classes. Is it "by design" functionality?
PawelP
 
Posts: 3
Joined: Thu Jan 05, 2012 11:57 am
Location: Poland

Postby james.davies » Mon Jan 16, 2012 6:12 pm

Hi,

The removal of custom attributes is not intended behaviour. Does it occur when there are no SA features enabled ?
Thanks,
James Davies
Technical Support Engineer
Red Gate Software
james.davies
 
Posts: 46
Joined: Tue Apr 19, 2011 2:39 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests