Bug? Generator type reverts when project re-opened

The simplest way to populate your database with test data.

Moderators: JonathanWatts, David Atkinson, Anu Deshpande, Michelle Taylor, Lionel, Emma A, sherr

Bug? Generator type reverts when project re-opened

Postby xavierj » Tue Dec 06, 2011 7:46 pm

Hi. I am using 2.0.0.69, and have a concern.

I created a generator that pulls data from another table for two columns. It works great!

When I save the project and re-open it, the two columns revert back to the "RegExpGenerator" and "Description" generator. As this table is a foreign key for other tables, it ends up creating a mess.

The saved project file clearly shows (to me) that what's saved is just as I configured - the XML for two columns have the text "<GeneratorTypeName>RedGate.SQLDataGenerator.Generators.DataBound.DataPassthroughGenerator</GeneratorTypeName>"


What am I doing wrong here? Tedious. Thanks!
xavierj
 
Posts: 1
Joined: Tue Dec 06, 2011 7:35 pm

Postby Chris Auckland » Wed Dec 07, 2011 8:57 pm

Thanks for your post.

I emailed you about this earlier, but I thought I would update the post in case anyone else finds the same problem.

This issue is a bug with SQL Data Generator 2.0 and has been logged with the internal tracking code SDG-972.

SQL Data Generator v1 doesn't have this problem, which can be downloaded from here
Chris
Chris Auckland
 
Posts: 757
Joined: Tue Oct 24, 2006 2:12 pm
Location: Red Gate Software Ltd.


Return to SQL Data Generator 2

Who is online

Users browsing this forum: No registered users and 0 guests