Performance Profiler is not working at all

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Postby Brian Donahue » Mon Oct 24, 2011 2:07 pm

If you open a command prompt and run netstat -a -b this should tell you which program is already listening on the port. Then you can close that program. Or choose a different port.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby arame3333 » Mon Oct 24, 2011 5:28 pm

I am surprised that I have to do that.
Anyway I did what you suggested.
In the virtual directory I put /http://localhost:2558/
For the Port to bind web server I put in one of the port numbers that came back from that command you gave me.
Now I get a launch. The error message on the launched web page is; HTTP Error 400 - Bad Request.
Make the impossible possible, the possible easy, and the easy elegant. — Moshe Feldenkrais
arame3333
 
Posts: 11
Joined: Thu Oct 13, 2011 4:18 pm
Location: London, UK

Postby Brian Donahue » Tue Oct 25, 2011 11:41 am

In the settings for "profile hosted in development webserver", the virtual directory specification is the part after the server and port. Usually just a forward-slash / is good enough.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby arame3333 » Tue Oct 25, 2011 4:08 pm

I do not know what you mean by "profile hosted in development webserver".
I tried putting a forward slash in the Web Server virtual directory, but that did not work.
Make the impossible possible, the possible easy, and the easy elegant. — Moshe Feldenkrais
arame3333
 
Posts: 11
Joined: Thu Oct 13, 2011 4:18 pm
Location: London, UK

Postby Brian Donahue » Tue Oct 25, 2011 4:19 pm

There are two ways to profile a web application in the profiler project settings. Hosted in IIS and Hosted in development web server. The one that has the box for virtual directory is development webserver. So I assume you're using that.

And now what does it do? It should not be a bad request. It did that because you seem to have put an entire URL in the virtual directory box.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Postby arame3333 » Tue Oct 25, 2011 4:44 pm

According to my previous message, I put in /http://localhost:2558/
Is that wrong?
Make the impossible possible, the possible easy, and the easy elegant. — Moshe Feldenkrais
arame3333
 
Posts: 11
Joined: Thu Oct 13, 2011 4:18 pm
Location: London, UK

Postby Brian Donahue » Mon Nov 07, 2011 11:51 am

Please send another screenshot. If you follow the instructions I have been giving, it should work.
Brian Donahue
 
Posts: 6669
Joined: Mon Aug 23, 2004 10:48 am

Previous

Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 0 guests