"Profiling stopped" immediately after I start profiling .XAP

Memory profiling for .NET developers

Moderators: Luke Jefferson, StephenC, AndrewH, melvyn.harbour, james.billings, Laura Morley, dene.boulton

"Profiling stopped" immediately after I start profiling .XAP

Postby bboy » Mon Mar 28, 2011 11:38 pm

Hi all,

I am running into a whole lot of issues and generally having a bad time with ANTS Memory profiler - I hope that someone will be able to help, else my license is going to be a big waste of $ and I'm going to be unhappy.

Now, I'm guessing there is something peculiar about my setup because I just cannot get a Silverlight Out of browser (OOB) to start profiling.

I get "Profiling stopped" immediately after I start profiling a .XAP directly. In some cases the OOB shows and in other cases, it doesn't show at all (different XAPs).

The logs show a message:

[Profiler pipe monitor] WARN RedGate.Profiler.Engine.Startup.Basic.PipeConnection - Rejected a connection attempt from process ID 0x1118 'C:\\Program Files (x86)\\Microsoft Silverlight\\sllauncher.exe'

- I've tried a bunch of different .xaps (so it's not that).
- I've reinstalled.
- I've tried using version 7 trial. (no luck) my license is for version 6 btw.
- In-browser works - but I need to profile OOB specific issues.

I want to focus on the issue above, but in case it's related - I also get an unhandled exception if I click on "Attach to a .NET 4 Process". I see the inner exception in the log says "RedGate.Memory.UI.UIFactory - System.UnauthorizedAccessException".

Please Help!? Any would be appreciated. Thanks.
bboy
 
Posts: 1
Joined: Mon Mar 28, 2011 10:19 pm

Postby Brian Donahue » Wed Mar 30, 2011 10:24 am

We are already working on this issue via email. It's not going to be a simple answer due to the way Profiler interacts with code being profiled, unfortunately.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby daShader » Tue Oct 11, 2011 12:39 am

I am having this very same issue. Was the cause for this identified? Is there some kind of fix?

10 Oct 2011 16:34:00.530 [Profiler pipe monitor] WARN RedGate.Profiler.Engine.Startup.Basic.PipeConnection - Rejected a connection attempt from process ID 0xa6c 'C:\\Program Files (x86)\\Microsoft Silverlight\\sllauncher.exe'
daShader
 
Posts: 1
Joined: Tue Oct 11, 2011 12:35 am

Postby Brian Donahue » Tue Oct 11, 2011 9:11 am

Sorry, no, the support call ended with no solution. I think he ended up running on another machine, in the end.

When profiler gets a connection coming in from a process being profiled, it checks that against a list of processes it expects to be profiled. sllauncher.exe isn't matching the list.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby Brian Donahue » Tue Oct 11, 2011 9:22 am

Ah, maybe it's not that simple - as with most things in the murky world of the Profiler code. Do you also see this in the log?
Unable to connect to profiler: do not know how to send settings
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am

Postby Brian Donahue » Mon Oct 17, 2011 2:25 pm

Can you please try the following:
  • Profile a .NET Executable
  • In the executable, use c:\\windows\\system32\\cmd.exe
  • In the arguments, use /K ""c:\\program files (x86)\\microsoft silverlight\\sllauncher.exe"/emulate:"c:\\YourOOBAppFolder\\YourOOBApp.xap" /origin:"c:\\YourOOBAppFolder" /overwrite"
  • Start profiling

Basically, it looks like the Silverlight launcher exits and re-launches. cmd /K will keep the command window open so ANTS Memory Profiler will connect to anything that runs in that console session.
Brian Donahue
 
Posts: 6668
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Memory Profiler 7

Who is online

Users browsing this forum: No registered users and 0 guests