Profiling a ASP.NET website does not work

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Profiling a ASP.NET website does not work

Postby RDas » Fri Aug 05, 2011 3:03 pm

Hi,
I am trying to profile an ASP.NET 2.0 web site using ANTS Performance profiler 6.3. I am using the "web development server" option to profile as I don't have IIS on my local machine in office. When I click on "Start profiling", it spawns a new IE but doesnot open the page I mentioned in the ASP.NET web application (path) field. Instead, it displays the list of files in the browser as hyperlinks. When I click on any of the aspx page, it reports one or the other error(e.g. parser error - masterpage not found). When I run the same application from VS 2008, it works without any problem. Could you please help me on this?

Thanks & Regards,
Rahul
RDas
 
Posts: 1
Joined: Fri Aug 05, 2011 2:49 pm

Postby Brian Donahue » Mon Aug 08, 2011 10:17 am

Hello Rahul,

The problem is that with development web server, the opening page is not opened and the default page is not opened, leading to a view of the directory list of files in the application root. We have logged this as a bug and the workaround is just to click on the default page or whatever page you want to use to start the session.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 0 guests