Custom Webserver for Automated Error Reporting

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Custom Webserver for Automated Error Reporting

Postby cfs80 » Thu Jul 28, 2011 8:41 am

Hi

We just purchased a license on SA 6 and are now trying to set up a Custom web server for error reporting. We have managed to receive e-mails regarding error reports but haven't received any actual reports to the custom webserver. The webservice is up and running. We have created a folder called saReports on the root of server. When we write the following in webconfig:
<add key="ReportsFolder" value="c:\\saReports"/>
We get e-mail but no actual reports in the folder saReports.
We have also tried the following in the webconfig:
<add key="ReportsFolder" value="~\\saReports\\"/>
but then we receive no e-mail nor a report?
This is the folder attributes (Swedish but you can see the numerical value):
Image

Please advice.

Brgds
Christian
cfs80
 
Posts: 1
Joined: Thu Jul 28, 2011 8:24 am

Postby Brian Donahue » Fri Jul 29, 2011 10:30 am

Hello,

If you get emails and no error reports are getting saved, it's probably a lack of write access for the IIS application pool identity account to the folder where the error reports are saved. (c:\\sareports)

I think we have established that the screenshot is for the FTP access, which is not necessarily the same as the filesystem access if it is enforced by the FTP server's security subsystem.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests