Retrieving Schema - Registering Databases

Compares and synchronizes SQL database content.

Moderators: Chris Auckland, David Atkinson, richardjm, david connell

Retrieving Schema - Registering Databases

Postby JamieA » Thu Jul 28, 2011 10:58 am

Hi, I am trying to run data compare 9 with a database being compared to a backup. The backup sets registered fine, but on the second tab, "tables and views", it is just sitting there saying "Retrieving Schema Registering Databases 0%". The backup is about 2 gigs. It has been running for 15 minutes. Is this behaviour normal, or do I need to do something?

Hope you can help,


Jamie
JamieA
 
Posts: 9
Joined: Thu Jul 28, 2011 10:54 am
Location: United Kingdom

Postby JamieA » Thu Jul 28, 2011 11:26 am

It just required patience - I just checked back and it has sorted itself out.

It's probably because too much metadata was being compared - I am new to SC9, must suss out the project options!

Jamie
JamieA
 
Posts: 9
Joined: Thu Jul 28, 2011 10:54 am
Location: United Kingdom

Postby David Atkinson » Thu Jul 28, 2011 12:24 pm

Can I ask what your use case is? You might want to look at SQL Virtual Restore as an alternative mechanism to query a backup. It's faster and provides you an actual database you can interact with.
David Atkinson
 
Posts: 1124
Joined: Mon Dec 05, 2005 4:54 pm
Location: Twitter: @dtabase

Postby JamieA » Thu Jul 28, 2011 1:03 pm

Yes - that would be the tool for the job - but it's not installed on this server :(
JamieA
 
Posts: 9
Joined: Thu Jul 28, 2011 10:54 am
Location: United Kingdom


Return to SQL Data Compare Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests