Difficulty with missing .net version

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, melvyn.harbour, dom.smith

Difficulty with missing .net version

Postby Uniwares_AS » Wed Jul 20, 2011 1:41 am

I do have a certain problem with SA and missing .net versions.

When an obfuscated app needs for example .net 3.5 and its not installed, the app starts and does "nothing". Of course the automated error reporting sends an message that System.Core v3.5 was not found. But that is not helpful at all for the user or admin.

Is there any way to avoid this specific problem to be caught and reported instead of reporting to the user?
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm

Postby Brian Donahue » Thu Jul 21, 2011 10:54 am

I'm assuming you've implemented a custom error dialog or have chosen the option not to display a dialog. Since this is a technically a binding failure, it will happen before the window pops up. All I can think to do is use the SDK to create a custom error handler that displays a window when there is a binding failure and to report silently on any other type of exception.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby Uniwares_AS » Thu Jul 21, 2011 2:27 pm

I am using the default reporting without userinterface.
Yet the SDK solution is not available in the standard version of SA. :cry:
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm

Postby Brian Donahue » Thu Jul 21, 2011 2:57 pm

It's been awhile since I looked into anything like this, but if you implement your own custom "UnhandledExceptionHandler" I think you may be able to put something in there that will display a messagebox on a binding failure. Have you tried it?
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby Uniwares_AS » Thu Jul 21, 2011 5:56 pm

If I remember right, without the SDK you can have one or the other but I will have a look at it.

Anyway would be great if SA would be able to handle this in a more end-user friendly way.
Uniwares_AS
 
Posts: 132
Joined: Thu Oct 11, 2007 3:29 pm


Return to SmartAssembly 6

Who is online

Users browsing this forum: No registered users and 0 guests