DLL Version Mismatch Woes

Automate and integrate using the SQL comparison API

Moderator: Chris Auckland

DLL Version Mismatch Woes

Postby clocklear » Fri Jul 15, 2011 12:39 pm

I'm trying to write an app that will do both schema comparison and data comparison and I'm running into issues. I need to use version 8 of the schema compare DLLs because I need access to the DifferenceFilter object, however the latest available version of the data compare objects is version 7. The release versions of the actual products is version 9. Why all the version differences? Is there a way that I can accomplish what I need to accomplish using what I have?

Also, I'm having issues properly licensing the objects. I've followed all available instructions, but when I attempt to license the DLLs in either the 'SQL Comparison SDK 8\\Assemblies\\SQL Packager' or 'SQL Comparison SDK 8\\Assemblies\\SQL Data Compare directories', I get the following error:

Exception occurred creating type 'RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine, Version=7.1.0.182, Culture=neutral, PublicKeyToken=7f465a1c156d4d57' System.IO.FileNotFoundException: Could not load file or assembly 'RedGate.Licensing.Client.resources, Version=2.7.0.3, Culture=en-US, PublicKeyToken=7f465a1c156d4d57' or one of its dependencies. Thesystem cannot find the file specified.

I've also tried just adding references to the DLLs in my 'SQL Data Compare 9' directory. Attempting to build an app with those DLLs just fails with no error code, regardless of what I do.

The only way I've been able to build my app is with just the DLLs in the 'SQL Comparison SDK 8\\Assemblies\\SQL Compare' directory. I got them licensed up and the app builds and runs beautifully. However, I can't do data comparison as the DLL is not present.

Any help or insight would be greatly appreciated.
clocklear
 
Posts: 2
Joined: Fri Jul 15, 2011 12:28 pm

Postby clocklear » Fri Jul 15, 2011 7:12 pm

I've managed to fix my own problems by using the v9 DLLs and dropping the .NET framework to 3.5 (previously I was using 4.0).
clocklear
 
Posts: 2
Joined: Fri Jul 15, 2011 12:28 pm


Return to SQL Comparison SDK Previous Versions

Who is online

Users browsing this forum: No registered users and 1 guest