Issue with 2.2 Mercurial Intergration

A SQL Server Management Studio add-in to source control your database in Subversion or Team Foundation Server.

Moderators: Chris Auckland, David Atkinson

Issue with 2.2 Mercurial Intergration

Postby CTSPatrick » Tue Jul 05, 2011 9:57 pm

I have run into a issue with the RedGate Source Control 2.2 when trying to commit changes to a mercurial repository.

If the underlying mercurial commit fails due to some exception (such as the message being empty) the whole commit process will simply stay in a "busy/doing work" state at the "Sending files to source control server" step.

Only attempting to close the window or pressing the cancel button will bring up the dialog box showing the mercurial error.
This was not happening in 2.1
CTSPatrick
 
Posts: 2
Joined: Tue Jul 05, 2011 9:53 pm

Postby james.billings » Fri Jul 08, 2011 9:50 am

Thanks for reporting this. I've let the team know so we can see if we can work out the problem. Is it consistently reproducible? Do you have other users who get the same problem?
james.billings
 
Posts: 1144
Joined: Wed Jun 16, 2010 11:10 am
Location: My desk.

Postby DavidSimner » Fri Jul 08, 2011 2:41 pm

I've tried to reproduce this on my machine and at the step you mentioned Notepad is correctly launched so that a new commit message can be entered. When I entered a new commit message in Notepad, saved the file, and closed Notepad, the commit in SQL Source Control finished successfully.

Can I just double-check with you that Notepad definitely isn't launched? On my machine it was set to be the active window, but can you please carefully check to see if it was launched, but because it wasn't made the active window you didn't notice it.

It is mercurial itself that is launching Notepad (SQL Source Control just asks mercurial to do the commit, and it decides to launch Notepad), so is there any chance you could have configured mercurial not to launch Notepad? This setting could be in the hg command line or in TortoiseHg.
DavidSimner
 
Posts: 49
Joined: Thu Feb 04, 2010 6:05 pm

I think I've got it

Postby CTSPatrick » Mon Jul 11, 2011 4:55 pm

I have now realized that I am using a command line editor (vim) to enter in my comments. What I suppose is happening is that no command terminal pops up with the vim instance, thus disabling my ability to leave a comment.

I am a heavy command line user and would greatly appreciate some support for this kind of issue.
CTSPatrick
 
Posts: 2
Joined: Tue Jul 05, 2011 9:53 pm

Postby DavidSimner » Tue Jul 12, 2011 10:24 am

Aah, that would explain it. Can you please give me the details for how you've configured vim to be your text editor, so that I can reproduce the issue here and looking into fixing it.

Thanks!
DavidSimner
 
Posts: 49
Joined: Thu Feb 04, 2010 6:05 pm


Return to SQL Source Control 2

Who is online

Users browsing this forum: No registered users and 0 guests