Unable to see API code i.e Wcf service while profiling

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Unable to see API code i.e Wcf service while profiling

Postby kartikas » Tue Jun 14, 2011 10:15 am

Hi all,

I am new to the ANTS performance profiler,when I profiling the application through Ants performance pofiler i am able to see the UI portion code i.e all the methods and classes which are used in the UI part.
But i am unable to see the API code(which is a WCF service and called by the UI)
please tell me to see the API code what should i do???


Thank you in Advance....
Kartika
kartikas
 
Posts: 2
Joined: Tue Jun 14, 2011 10:03 am

Postby Brian Donahue » Tue Jun 14, 2011 11:10 am

Since the WCF service is running in another process not directly started by the process you are profiling, you will have to profile the WCF service process separately. You would more than likely profile a web application, although a WCF service doesn't necessarily have to be hosted in IIS.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby kartikas » Wed Jun 15, 2011 9:59 am

Thanks for your reply of my previous post
when profiling my wcf service i am geeting below error.

Failed to connect to target Process because an exception occured:
could not strat IIS,please check ur setting and start again.

Note:I checked IIS seeting, its ok
my Wcf service is also running in IIS and Browser

Could you please tell me what are the setting needed to start profiling the wcf service and please explain me what are the modification needed in IIS setting to profiling the wcf service???

Thank you in adavance
Kartika
kartikas
 
Posts: 2
Joined: Tue Jun 14, 2011 10:03 am

Postby Brian Donahue » Wed Jun 15, 2011 10:13 am

I can't say for sure because it depends on your environment but I can give advice.

Typically a WCF service is hosted in IIS and a "contract" exists binding it to a particular port. So you can try "profile on original port" and if that doesn't work, try "profile on unused port" and when it starts, shut down the website hosting the WCF in IIS.

It could also be the common problem that ANTS Profiler changes the WCF's running environment and makes it crash. In that case the website needs to be debugged. We can open a support ticket and send you instructions for dumping the memory if it comes to that.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 0 guests