Data Script not getting created

Packages and compresses schema and contents of SQL Server databases

Moderators: JonathanWatts, Chris Auckland, David Atkinson, david connell, Anu Deshpande, Michelle Taylor, james.billings, Marianne

Data Script not getting created

Postby leosperry » Thu Mar 17, 2011 8:37 pm

I am trying to create a script for our build process that will create a new db from scratch so that I can include it with our installer.

I'm Calling the Sql Packager like this

Code: Select all
SQLPackager.exe /argfile:c:\\temp\\PackageSettings.xml


Here is the contents of PackageSettings.xml:

Code: Select all
<?xml version="1.0"?>
<commandline>
   <force/>
   <verbose/>
   <out>c:\\temp\\output.txt</out>
   
   <makescript/>
   <scriptdestination>c:\\temp</scriptdestination>
   
   <server1>localhost</server1>
   <database1>MyDb</database1>    
      
   <schemascript>c:\\temp\\CreateDB.sql</schemascript>
   <datascript>c:\\temp\\DefaultData.sql</datascript>
   
   <includeschema>Table</includeschema>
   <includeschema>StoredProcedure</includeschema>
   <includeschema>View</includeschema>
   
   <includedata>Table</includedata>

</commandline>


With the above set up, I only get CreateDB.sql. It never creates DefaultData.sql.

How do I get it to make the data script?

If I could get it to make a single script like the GUI does that would be even better.

I have not seen the scriptdestination tag make any difference. What does it affect? Why is it required if it doesn't change anything?
leosperry
 
Posts: 2
Joined: Thu Feb 10, 2011 8:42 pm

Fixed, But Why?

Postby leosperry » Thu Mar 17, 2011 11:08 pm

I had to run as an admin 1 time. Now it works. I was getting some kind of error that asked to run as an admin.

My environment is Win 7 64bit
leosperry
 
Posts: 2
Joined: Thu Feb 10, 2011 8:42 pm


Return to SQL Packager 6

Who is online

Users browsing this forum: No registered users and 0 guests