Debugging Assemblies in VS2010 for Windows Phone 7

Explore, browse and analyze .NET assemblies

Moderators: Luke Jefferson, Charles Brown, StephenC, Alex.Davies, Greg.Tillman, melvyn.harbour

Debugging Assemblies in VS2010 for Windows Phone 7

Postby jeffamaphone » Fri Feb 04, 2011 1:37 am

I'm trying to debug a class method in Microsoft.Phone.Notifications, but I keep getting the error:

"The loaded assembly "Microsoft.Phone" is not the one .NET reflector expected... etc."

In the modules window the one I loaded has no absolute path, but Reflector is expecting one that has a very long path in front of it. Also, the one that is loaded has no symbols.

I have checked Microsoft.Phone in the list of assemblies to debug in the reflector menu item.

Is this an issue with Phone 7 (like, it's loading the module on the phone / emulator, and not my machine?) or am I doing it wrong?

Thanks.
jeffamaphone
 
Posts: 1
Joined: Fri Feb 04, 2011 1:34 am

Postby Clive Tong » Fri Feb 04, 2011 11:03 am

We cannot currently get Visual Studio to load our pdb file. To get it to do so requires that we know the pdb signature of the assembly for which we are generating pdb information. Unfortunately, the assembly is hosted inside the emulator and can't be accessed from the outside, so we can't get to it.

We have the issue in our bug tracking system as RP-704
Clive Tong
 
Posts: 283
Joined: Thu Dec 04, 2008 5:42 pm


Return to .Net Reflector 6.x and .NET Reflector 6.x Pro

Who is online

Users browsing this forum: No registered users and 0 guests