Not sending out email

Forum for users of Aardvark bug tracking system

Moderator: Brian Donahue

Not sending out email

Postby rbailey » Wed Oct 19, 2005 11:47 am

Hi,

We are having a problem with the email notifications not being sent out.

We have recently integrated our servers with our head office, and have moved from our old exchange server to a new exchange 2003 server.

Since the change, we are unable to get the email notification working.

We updated the registry settings for Aardvark and rebooted the server. Everything else seems to be working correctly.

The service is running as an administrator on the local machine.

There are no .xml files in the root of the folder called 'New Queue'. There is a sent and failed folder within this containing many .xml files. The .xml files in the failed folder appear to be the current email notifications.
Where would the errors be logged if the problem was here?

The is no queued mail on the exchange server, and no logs of any activity from the Aardvark account.

We have checked the exchange server to make sure it has the option to allow mail relay.

Any help with this would be greatly appreciated.

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Wed Oct 19, 2005 3:40 pm

Hello Richard,

More than likely the issue is that the new Exchange Server does not allow mail relay from the Aardvark server, which is the default, and very sensible setting. You should get the Exchange Server admin to allow relay from the IP address of the Aardvark Server. There are other potential configuration issues, such as the SMTP server requiring authentication.

The Exchange server itself may also reveal the reason why you cannot send mail. If you open a command prompt on the Aardvark server, then run ‘telnet <name of exchange server> 25’. This will allow you to run SMTP commands on the Exchange Server. If the connection is successful, try sending a test message using these commands:

HELO <return>
MAIL FROM:<your email address><return>
RCPT TO:<your address><return>
DATA<return>
Subject:Test Message<return>
Just Testing!!!<return>
<return>
<return>
.<return>
QUIT<return>

You should get the email in your inbox. If you do not, please let me know.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Problem with permission accessing server

Postby rbailey » Thu Oct 20, 2005 3:04 pm

I have confirmation from our IT department that Mail relay is allowed and authentication is not required.

I tried to Telnet the server as per your instructions. The connection is made with the server, but when I type the MAIL FROM: command, I get an error stating "client does not have permission to submit mail to this server".

Do you have any more suggestions as to what could be causing the problem?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Thu Oct 20, 2005 4:57 pm

Hi Richard,

I think perhaps someone is not being totally honest with you!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby rbailey » Fri Oct 21, 2005 4:07 pm

Hi Brian,

You appear to right about that. I got them to show me, and they have the basic authentication and integrated windows authentication boxes checked.

I have also been informed that I will not be allowed to change the server configuration by allowing anonymous access.

Is there a work around we can use here?

I was also looking at creating an external pop3 email account, but they all seem to require authentication for outgoing mail. I don't mind using this instead of our exchange server, providing there is a way we can get around this?

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Fri Oct 21, 2005 6:50 pm

There is no support for SMTP authentication in Aardvark.

If you cannot get them to open the relay for you, I may be able to send a fix for it in a week or two. It's easy to do, but I'm having some technical problems getting a build out for you.

It would be much better if you could just convince them to allow anonymous relay from your server.
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am

Postby rbailey » Tue Oct 25, 2005 3:55 pm

Hi Brian,

I've finally convinced them to allow mail relay from the server. We will not need the fix for SMTP authentication now.

Thank you very much for your help with this. I was at a complete loss with the IT department telling me that mail relay was already allowed.

It all appears to be working correctly. I can get back to harassing the developers with hundreds of emails from Aardvark now.

Thanks,

Richard.
rbailey
 
Posts: 12
Joined: Wed Oct 19, 2005 11:05 am

Postby Brian Donahue » Fri Oct 28, 2005 11:16 am

Excellent! Thanks for getting in touch with us!
Brian Donahue
 
Posts: 6670
Joined: Mon Aug 23, 2004 10:48 am


Return to Aardvark

Who is online

Users browsing this forum: No registered users and 0 guests