Commas and Layout with Wildcard Expansion

Provides intelligent code completion for SQL Server editors.

Moderators: David Atkinson, Anu Deshpande, Luke Jefferson

Commas and Layout with Wildcard Expansion

Postby jcc105 » Mon Oct 05, 2009 2:38 pm

I am now using the nice and fast v4.0.2.53 standard edition in SQL 2005 Management Studio. One feature that seems significantly different from v3 is the layout when expanding the * wildcard

When I expand
Code: Select all
   SELECT
      pd.*
   FROM
      #tmpProductOrderDetails pd


I now get

Code: Select all
   SELECT
      SiteNumber ,
              ReconciledDateTime ,
              ProductCode ,
              ProductDescription ,
              ProductQuantity
   FROM
      #tmpProductOrderDetails pd


instead of

Code: Select all
   SELECT
      SiteNumber,
      ReconciledDateTime,
      ProductCode,
      ProductDescription,
      ProductQuantity
   FROM
      #tmpProductOrderDetails pd


There is the additional <tab> character (2 actually I think) before the second and subsequent column names, and there is now a space before each comma. I notice that the comma at least can be turned off in the pro version, but as it was turned off by default in v3 is this just an underhand way of expecting me to upgrade to put the formatting back to how it used to be?

Is anyone else having a similar tabbing issue?

Thanks
Chris
Last edited by jcc105 on Wed Feb 24, 2010 12:22 pm, edited 1 time in total.
jcc105
 
Posts: 5
Joined: Mon Oct 05, 2009 2:24 pm

Postby Anu Deshpande » Tue Oct 06, 2009 4:08 pm

Many thanks for your post and explanation.

I was able to replicate the issue hence I have logged this in our internal tracking system whose unique id is SP-2838.

I will update you as soon as I get any details on it's progress.

Sorry for the inconvenience caused by this issue and thanks for your patience.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Not fixed in 4.0.3.12

Postby Matt_B » Wed Nov 18, 2009 11:35 pm

I was hoping this issue (SP-2838) would be fixed in yesterday's update, but this doesn't seem to be the case.

Can you give any idea when it might be addressed?

Thanks,

Matt
Matt_B
 
Posts: 9
Joined: Tue Feb 19, 2008 8:58 am

Postby Anu Deshpande » Wed Nov 25, 2009 12:37 pm

Many thanks for your post Matt and apologies that this bug was not fixed in the recent release.

We do not have a fixed date yet as soon as this bug is fixed and when we pin down a date I will update this forum.

Thanks for your patience and co-operation.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby jcc105 » Wed Feb 24, 2010 12:41 pm

I see that this incident is also logged as SP-2796 but neither made it into v4.0.3.12 and don't seem tobe on the list for 4.0.4.11

Is there any news on any potential future release it may be in?
jcc105
 
Posts: 5
Joined: Mon Oct 05, 2009 2:24 pm

Postby CodantiM » Tue Apr 06, 2010 4:52 pm

It appears from what I have heard that Red Gate doesn't think this issue impacts many people, and it isn't slated to be fixed in version 5 that they are working on now. If you experience this bug and would like to see it fixed speak up now so that maybe they will add it to their list to fix.
CodantiM
 
Posts: 182
Joined: Fri Jun 29, 2007 2:07 am

Postby Anu Deshpande » Thu Sep 02, 2010 3:37 pm

Many thanks for your patience with this issue.

This issue is fixed in EAP 5 of SQL Prompt for more information click here.
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Anu Deshpande
 
Posts: 692
Joined: Mon Apr 20, 2009 3:53 pm
Location: Cambridge

Postby jcc105 » Thu Sep 02, 2010 4:27 pm

Cool ... thank goodness I just renewed my support and maintenance!
jcc105
 
Posts: 5
Joined: Mon Oct 05, 2009 2:24 pm

Postby jcc105 » Thu Jan 06, 2011 12:28 pm

I just installed SP (Standard) v5, but this problem still exists. Do you know when there will be an actual fix for it?
jcc105
 
Posts: 5
Joined: Mon Oct 05, 2009 2:24 pm


Return to SQL Prompt Previous Versions

Who is online

Users browsing this forum: No registered users and 0 guests