Strong name signing with a .pfx file fails

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, Alex.Davies, melvyn.harbour

Strong name signing with a .pfx file fails

Postby CSXPJC » Fri Nov 26, 2010 7:05 pm

I've signed my assemblies with a strong name using a .pfx file. I have pointed my SA project to the pfx file and enabled the option to re-sign after obfuscation.

However, when I run the obfuscation build the process fails:

Analyzing...
Preparing...
Creating Assembly...
ERROR: You have not entered the correct password for the key file.

I can't see anywhere in the SA project file or the UI to enter the password for my .pfx file.

How can I obfuscate if I've strong named using a .pfx file?
CSXPJC
 
Posts: 4
Joined: Fri Aug 27, 2010 11:18 am

Postby Alex.Davies » Mon Nov 29, 2010 11:29 am

Try un-setting the pfx file option, then re-setting it. I think we have a bug where if you select a new pfx file, it tries to use the old password, you may have encountered that.

There is a dialog to type the password that you should get.
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk


Return to SmartAssembly 5

Who is online

Users browsing this forum: No registered users and 0 guests