localization files on a XAP

.NET obfuscator and automated error reporting

Moderators: Luke Jefferson, Alex.Davies, melvyn.harbour

localization files on a XAP

Postby iosub » Tue Oct 19, 2010 3:57 pm

HI

We are evaluating your products.

we have silverlight .xap that is multi language (ES and EN) the original xap file has two directories inside for \"ES\" and \"EN\".

The converted .xap file after the obfuscation does not have these two directories so our .xap is not working.

We get the error
Message: Unhandled Error in Silverlight Application
Code: 2105
Category: InitializeError
Message: Failed to load pre-requisites for the application

As a workaround we have add these two directories to the converted .xap file and now is working

is this a bug? or we are missing something?

Thank you

More:
I have modify \"Sample 06 - Silverlight \" custom error template and There are also directories with different languages. These resources are not added to the xap files. Resulting that the custom template is not localized.
iosub
 
Posts: 19
Joined: Tue Oct 19, 2010 3:40 pm

Postby Alex.Davies » Wed Oct 20, 2010 12:11 pm

Thanks for the report.

The does sound like a bug to me, we hadn't thought about the localisation system and how it might affect xaps.

We'll have it fixed next version.

The workaround you used sounds good, if you can automate it enough for your purposes. Another workaround would be to obfuscate the copy of the dll in the obj directory at the AfterCompile step of building, details here:
http://www.red-gate.com/supportcenter/C ... 032253.htm
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk

Re:

Postby iosub » Thu Nov 04, 2010 8:20 pm

Alex.Davies wrote:Thanks for the report.

The does sound like a bug to me, we hadn't thought about the localisation system and how it might affect xaps.

We'll have it fixed next version.

The workaround you used sounds good, if you can automate it enough for your purposes. Another workaround would be to obfuscate the copy of the dll in the obj directory at the AfterCompile step of building, details here:
http://www.red-gate.com/supportcenter/C ... 032253.htm


Hi did you fix this on SA 6 EAP 83??

can I use my trial code for testing SA 6?

Thanks!
iosub
 
Posts: 19
Joined: Tue Oct 19, 2010 3:40 pm

Postby Alex.Davies » Fri Nov 05, 2010 2:12 am

No, I'm afraid it's not done yet, I'll try to remeber to let you know when it is.

The version 6 eaps each start a new 14 day trial for you to use, so you shouldn't have to worry about your trial expiring while you're using them.
Alex
Developer,
Red Gate .NET Tools
Alex.Davies
 
Posts: 335
Joined: Tue Dec 02, 2008 12:23 pm
Location: Cambridge, uk


Return to SmartAssembly 5

Who is online

Users browsing this forum: No registered users and 0 guests