Exception on Win7 when try to Profile with SQL Record

Code profiling for .NET Developers

Moderators: Luke Jefferson, StephenC, Alex.Davies, AndrewH, melvyn.harbour, Laura Morley

Exception on Win7 when try to Profile with SQL Record

Postby oliver » Thu Oct 28, 2010 12:25 pm

Hi,

if i try to Profile a .Net .exe Application with the following Settings:
- Method Line
- Record SQL

after a few Seconds i will get an Profiler-Exception Dialog.

If i try to profile without SQL recording, there is no problem.
This is what i found in the antsprofiler-xxx.log:

28 Oct 2010 13:07:50.997 [1] INFO RedGate.Profiler.Logging.LogService - Starting new ANTS Performance Profiler 6 session
28 Oct 2010 13:07:51.012 [1] INFO RedGate.Profiler.Logging.LogService - Assembly version: 6.0.0.1312
28 Oct 2010 13:07:57.315 [1] WARN RedGate.Profiler.OS.Local.LocalWindowsVersionInspector - Detected Windows version: Windows Vista Enterprise (6.1 64-bit)
28 Oct 2010 13:07:57.315 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is supported on installed OS version
28 Oct 2010 13:07:57.330 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if inetinfo.exe running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if W3SVC running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks suggest that IIS does not appear to be running.
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checking for existence of inetinfo.exe at 'C:\\Windows\\system32\\inetsrv\\inetinfo.exe'
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Unable to find inetinfo.exe
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if W3SVC running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not enabled.
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Successfully detected IIS installation: IIS 7 (Auto-detected) (Not verified) (Disabled)
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not installed.
28 Oct 2010 13:15:21.825 [1] ERROR RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Trigger process failed to start
28 Oct 2010 13:15:22.012 [1] ERROR RedGate.Profiler.UI.Ignition - SmartExceptionsCore.UnhandledException @ 7455, offset:27
28 Oct 2010 13:15:22.012 [1] ERROR RedGate.Profiler.UI.Ignition - SmartAssembly.SmartExceptionsCore.UnhandledException
28 Oct 2010 13:15:22.028 [1] ERROR RedGate.Profiler.UI.Ignition -


So i try to use Ants Performance Profiler on a fresh installed Windows7 OS.

Any idea?

Greetings
Oliver
oliver
 
Posts: 3
Joined: Thu Oct 28, 2010 12:18 pm

Postby nick.maidment » Thu Oct 28, 2010 1:31 pm

Hi Oliver,

I just sent you an email. Please let me know if you get it.

Anyone else running into a problem with the "Trigger Process" should contact support @ red-gate .com directly.
nick.maidment
 
Posts: 74
Joined: Fri Jan 29, 2010 1:55 pm

Postby oliver » Thu Oct 28, 2010 1:34 pm

Hi,

thank you for your reply.
I will try the patch.
oliver
 
Posts: 3
Joined: Thu Oct 28, 2010 12:18 pm

Postby oliver » Fri Oct 29, 2010 11:52 am

I tried your patch, but still the same.

I found the following entry on the old Log - File:
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not installed.

So i checked the OS-Installation and the InternetInformationService was not installed. I installed the IIS, now there is no exception.
oliver
 
Posts: 3
Joined: Thu Oct 28, 2010 12:18 pm


Return to ANTS Performance Profiler 6

Who is online

Users browsing this forum: No registered users and 0 guests